summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCôme Chilliet2015-12-11 23:36:26 +0700
committerCôme Chilliet2015-12-11 23:36:26 +0700
commitda1307bc565c6de1eaf5ffa074b1a354e7fa7284 (patch)
tree9e59601cc054572392c20d9c2fc6886e0fd22365
parent9003a93bfc9b1f4a9d1b229ba1e24f274aa861a6 (diff)
downloadaur-da1307bc565c6de1eaf5ffa074b1a354e7fa7284.tar.gz
Now using gendesk to create a desktop file
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7561dae4d994..4956e6b6dc90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,30 @@
# Mantainer: MCMic <come@chilliet.eu>
pkgname=anticube2-git
-pkgver=5c8fe63
+pkgver=f13b180
pkgrel=1
-pkgdesc="Interactive non-linear puzzle game based on Tesseract"
+pkgdesc="Interactive first person puzzle game based on Tesseract"
arch=('i686' 'x86_64')
url="http://quadropolis.us/node/4182"
license=('CC-BY')
depends=(tesseract-game)
-makedepends=('git')
+makedepends=('git' 'gendesk')
source=("git://github.com/Kvaleya/Anticube2.git")
md5sums=(SKIP)
_gitname='Anticube2'
+_exec='anticube2'
+_name='Anticube 2'
+_categories='Game;'
pkgver() {
cd ${_gitname}
git describe --always | sed 's|-|.|g'
}
+prepare() {
+ gendesk -n -f ../PKGBUILD
+}
+
package() {
cd ${srcdir}/${_gitname}
mkdir -p ${pkgdir}/usr/share/tesseract-game/
@@ -25,4 +32,6 @@ package() {
cp -r media ${pkgdir}/usr/share/tesseract-game/
echo -e "#!/bin/sh\ntesseract-game -x\"hudgun 0; ao 0\" -lac2" > ${pkgdir}/usr/bin/anticube2
chmod +x ${pkgdir}/usr/bin/anticube2
+ install -Dm644 "${srcdir}/anticube2.desktop" "$pkgdir/usr/share/applications/anticube2.desktop"
+ install -Dm644 "media/map/ac2.png" "$pkgdir/usr/share/pixmaps/anticube2.png"
}