summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Dewar2021-01-18 10:44:24 +0000
committerAlex Dewar2021-01-18 10:44:24 +0000
commit67f36d82d6ea65104a38a03a70320f37930413f4 (patch)
treecb3d1557854195de2159388389ce61c805f76fa5
parent5f96c9260a7b9233574cd5fc3ca83a033ad1b654 (diff)
downloadaur-67f36d82d6ea65104a38a03a70320f37930413f4.tar.gz
Fix package
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ed71017348d..6a87f56c4dc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = antidot-bin
pkgdesc = Cleans up your $HOME from those pesky dotfiles
+ pkgver = 0.5.0
+ pkgrel = 7
url = https://github.com/doron-cohen/antidot
- license = MIT
arch = x86_64
- pkgver = 0.5.0
- pkgrel = 6
- source = antidot-0.5.0.bin::https://github.com/doron-cohen/antidot/releases/download/v0.5.0/antidot_0.5.0_linux_amd64
+ license = MIT
+ provides = antidot
+ conflicts = antidot
+ source = antidot-0.5.0.bin::https://github.com/doron-cohen/antidot/releases/download/v0.5.0/antidot_0.5.0_Linux_x86_64.tar.gz
sha256sums = 1f2ea4b8fbca1bbac5483dc47dfd5695723176452bc1eecf0e9a9bc71c4fef9a
pkgname = antidot-bin
+
diff --git a/PKGBUILD b/PKGBUILD
index c239c91c14a7..82496a445dd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
# Maintainer: Doron Cohen <me@doron.dev>
pkgname=antidot-bin
-pkgdesc="Cleans up your $HOME from those pesky dotfiles"
+pkgdesc="Cleans up your \$HOME from those pesky dotfiles"
url="https://github.com/doron-cohen/antidot"
license=("MIT")
arch=("x86_64")
pkgver=0.5.0
-pkgrel=6
+pkgrel=7
provides=("antidot")
conflicts=("antidot")
depends=()
-source=("antidot-0.5.0.bin::https://github.com/doron-cohen/antidot/releases/download/v0.5.0/antidot_0.5.0_linux_amd64")
-sha256sums=("1f2ea4b8fbca1bbac5483dc47dfd5695723176452bc1eecf0e9a9bc71c4fef9a")
+source=("$url/releases/download/v0.5.0/antidot_0.5.0_Linux_x86_64.tar.gz")
+sha256sums=('1f2ea4b8fbca1bbac5483dc47dfd5695723176452bc1eecf0e9a9bc71c4fef9a')
package() {
- install -Dm 0755 "$srcdir/antidot-0.5.0.bin" "$pkgdir/usr/bin/antidot"
+ install -Dm 0755 "$srcdir/antidot" "$pkgdir/usr/bin/antidot"
}