summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArkadiy Illarionov2023-10-15 15:22:02 +0300
committerArkadiy Illarionov2023-10-15 15:51:43 +0300
commit508bb58775acb234e2003c626c761b1a8b62e8da (patch)
tree417ba5df9e9e5e0d60c5d897320c2af7f584d9b5
downloadaur-508bb58775acb234e2003c626c761b1a8b62e8da.tar.gz
Init antiduplx-git
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD56
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e722d38d548
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = antiduplx-git
+ pkgdesc = Command line tool to find and remove similar pictures
+ pkgver = 1.0.1.r28.895a50c
+ pkgrel = 1
+ url = https://github.com/ermig1979/AntiDuplX
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ makedepends = nasm
+ makedepends = ninja
+ depends = libjpeg-turbo
+ source = antiduplx-git::git+https://github.com/ermig1979/AntiDuplX.git
+ source = git+https://github.com/ermig1979/Cpl.git
+ source = git+https://github.com/ermig1979/Simd.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = antiduplx-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7cff0bb7135
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+pkgname=antiduplx-git
+_pkgver=1.0.1
+pkgver=1.0.1.r28.895a50c
+pkgrel=1
+pkgdesc="Command line tool to find and remove similar pictures"
+arch=('x86_64')
+url="https://github.com/ermig1979/AntiDuplX"
+license=(MIT)
+depends=(
+ libjpeg-turbo
+)
+makedepends=(
+ cmake
+ git
+ nasm
+ ninja
+)
+source=(
+ "$pkgname::git+$url.git"
+ "git+https://github.com/ermig1979/Cpl.git"
+ "git+https://github.com/ermig1979/Simd.git"
+)
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "%s.r%s.%s" "$_pkgver" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+prepare() {
+ cd "$pkgname"
+ git submodule init
+ git config submodule.3rd/Cpl.url "$srcdir/Cpl"
+ git config submodule.3rd/Simd.url "$srcdir/Simd"
+ git -c protocol.file.allow=always submodule update -- "3rd/Cpl" "3rd/Simd"
+}
+
+build() {
+ cd "$pkgname"
+
+ cmake -B build -G Ninja -S ./prj/cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DADX_USE_SYSTEM_TURBOJPEG=ON
+
+ cmake --build build
+}
+
+package() {
+ cd "$pkgname"
+
+ install -Dm755 "build/AntiDuplX" "$pkgdir/usr/bin/AntiDuplX"
+}
+
+# vim:set ts=2 sw=2 et: