summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2018-04-02 12:41:51 -0500
committerfrealgagu2018-04-02 12:41:51 -0500
commit1a54ad3cd13cd6248ca6040367082745f6baf8e0 (patch)
treee46325d294ceb0d364b92a3332f946a73e74ca3c
parent5092e5a96d09bf5aa8436fc5c92b4b086cdfb911 (diff)
downloadaur-1a54ad3cd13cd6248ca6040367082745f6baf8e0.tar.gz
Removing unused dependencies, adding maintainer tag
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD8
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db562a317ed2..4ced28226a1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = antimicro
- pkgdesc = Graphical program used to map keyboard keys and mouse controls to gamepad buttons
+ pkgdesc = Graphical program used to map keyboard keys and mouse controls to a gamepad
pkgver = 2.23
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/AntiMicro/antimicro
arch = i686
arch = x86_64
@@ -10,12 +10,9 @@ pkgbase = antimicro
makedepends = gettext
makedepends = itstool
makedepends = qt5-tools
- depends = desktop-file-utils
- depends = libxkbcommon-x11
depends = libxtst
depends = qt5-base
depends = sdl2
- depends = shared-mime-info
source = antimicro-2.23.tar.gz::https://github.com/AntiMicro/antimicro/archive/2.23.tar.gz
sha256sums = ef309170612da805992f9194f1973bf38a3174a0856856afedab67f9d927a9ef
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..61908dc789b1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+antimicro-*.pkg.tar.xz
+antimicro-*.tar.gz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index d2393782b100..9728e865e9ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: grimi <grimi at poczta dot fm>
+# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
# Maintainer: Thomas Nordenmark <t.nordenmark@gmail.com>
# Developer: Travis Nickles <nickles.travis@gmail.com>
pkgname=antimicro
pkgver=2.23
-pkgrel=2
-pkgdesc="Graphical program used to map keyboard keys and mouse controls to gamepad buttons"
+pkgrel=3
+pkgdesc="Graphical program used to map keyboard keys and mouse controls to a gamepad"
arch=("i686" "x86_64")
url="https://github.com/AntiMicro/${pkgname}"
license=("GPL3")
-depends=("desktop-file-utils" "libxkbcommon-x11" "libxtst" "qt5-base" "sdl2" "shared-mime-info")
+depends=("libxtst" "qt5-base" "sdl2")
makedepends=("cmake" "gettext" "itstool" "qt5-tools")
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/AntiMicro/${pkgname}/archive/${pkgver}.tar.gz")
sha256sums=("ef309170612da805992f9194f1973bf38a3174a0856856afedab67f9d927a9ef")
@@ -35,7 +36,6 @@ build() {
package() {
cd "${pkgname}-${pkgver}/build"
-
make DESTDIR="${pkgdir}" install
}