summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMishima, Saburouta2018-04-03 22:35:22 -0500
committerMishima, Saburouta2018-04-03 22:35:22 -0500
commitae2fb797b424e5485af3e8d0b45c753eca552689 (patch)
tree38bc25d428cceeac56d3da347f480b520b77aa40
parentff069d1f8fd15d40f9e8daeaa0447d0e4d464035 (diff)
downloadaur-ae2fb797b424e5485af3e8d0b45c753eca552689.tar.gz
fix: frealgagu's fix for cpp_wrap build failure
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD33
2 files changed, 28 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f04fdd31fe4b..a5c126e53a7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = antimicro-git
pkgdesc = Map keyboard and mouse actions to gamepad buttons, inspired by qjoypad.
- pkgver = 2.17.r22.ge19415e
- pkgrel = 1
+ pkgver = 2.23.r14.gecec251
+ pkgrel = 2
url = https://github.com/antimicro/antimicro
install = antimicro-git.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 29518efc4627..4cd565be7d69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
pkgname=antimicro-git
-pkgver=2.17.r22.ge19415e
-pkgrel=1
+_name=${pkgname%%-git}
+pkgver=2.23.r14.gecec251
+pkgrel=2
pkgdesc='Map keyboard and mouse actions to gamepad buttons, inspired by qjoypad.'
url='https://github.com/antimicro/antimicro'
@@ -10,8 +11,8 @@ license=('GPL3')
depends=('libxtst' 'qt5-base' 'sdl2')
makedepends=('git' 'cmake' 'qt5-tools' 'itstool')
-provides=('antimicro')
-conflicts=('antimicro')
+provides=( "$_name" )
+conflicts=( "$_name" )
source=('git://github.com/antimicro/antimicro')
install='antimicro-git.install'
@@ -19,12 +20,30 @@ install='antimicro-git.install'
md5sums=('SKIP')
pkgver() {
- cd antimicro
+ cd "$_name"
git describe | sed 's/-/.r/; s/-/./'
}
+
+prepare() {
+ read -p '
+Use fix suggested by rakuco via AUR'"'"'s frealgagu? (Do not call QT5_WRAP_CPP.)
+> See: https://github.com/AntiMicro/antimicro/pull/207/files
+> Fix: sed -i "/QT5_WRAP_CPP/d" "${srcdir}/${_name}/CMakeLists.txt"
+[y/n]?
+' C
+ [[ "$C" =~ 'y' ]] && {
+ set -x;
+ sed -i "/QT5_WRAP_CPP/d" "${srcdir}/${_name}/CMakeLists.txt";
+ set +x;
+ } || {
+ echo "NOT sedding...";
+ }
+}
+
+
build() {
- cd antimicro
+ cd "$_name"
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DUSE_SDL_2=ON \
-DWITH_XTEST=ON \
@@ -34,6 +53,6 @@ build() {
}
package() {
- cd antimicro
+ cd "$_name"
make DESTDIR="$pkgdir" install
}