summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Golatofski2020-01-20 19:39:49 +0100
committerFelix Golatofski2020-01-20 19:39:49 +0100
commitbb25b1e5022695416394eb9d37fe6ae6cd8ed94f (patch)
tree0293f614031ff7730a05b32a721dcdd0e02ff605
parentae2fb797b424e5485af3e8d0b45c753eca552689 (diff)
downloadaur-bb25b1e5022695416394eb9d37fe6ae6cd8ed94f.tar.gz
Updated source
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD58
2 files changed, 34 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5c126e53a7d..3c3325346a52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,26 @@
pkgbase = antimicro-git
pkgdesc = Map keyboard and mouse actions to gamepad buttons, inspired by qjoypad.
- pkgver = 2.23.r14.gecec251
- pkgrel = 2
- url = https://github.com/antimicro/antimicro
+ pkgver = 2.23.r421.gf3c11e5
+ pkgrel = 1
+ url = https://github.com/juliagoda/antimicroX
install = antimicro-git.install
arch = i686
arch = x86_64
license = GPL3
- makedepends = git
makedepends = cmake
- makedepends = qt5-tools
+ makedepends = extra-cmake-modules
+ makedepends = gettext
makedepends = itstool
+ makedepends = qt5-tools
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
depends = libxtst
depends = qt5-base
depends = sdl2
- provides = antimicro
- conflicts = antimicro
- source = git://github.com/antimicro/antimicro
- md5sums = SKIP
+ provides = antimicroX
+ conflicts = antimicroX
+ source = git://github.com/juliagoda/antimicroX
+ sha512sums = SKIP
pkgname = antimicro-git
diff --git a/PKGBUILD b/PKGBUILD
index 4cd565be7d69..70b63ed69c9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,44 @@
pkgname=antimicro-git
-_name=${pkgname%%-git}
-pkgver=2.23.r14.gecec251
-pkgrel=2
+_name=antimicroX
+pkgver=2.23.r421.gf3c11e5
+pkgrel=1
pkgdesc='Map keyboard and mouse actions to gamepad buttons, inspired by qjoypad.'
-url='https://github.com/antimicro/antimicro'
+url='https://github.com/juliagoda/antimicroX'
arch=('i686' 'x86_64')
license=('GPL3')
-depends=('libxtst' 'qt5-base' 'sdl2')
-makedepends=('git' 'cmake' 'qt5-tools' 'itstool')
+depends=("desktop-file-utils" "hicolor-icon-theme" "libxtst" "qt5-base" "sdl2")
+makedepends=("cmake" "extra-cmake-modules" "gettext" "itstool" "qt5-tools")
provides=( "$_name" )
conflicts=( "$_name" )
-source=('git://github.com/antimicro/antimicro')
+source=('git://github.com/juliagoda/antimicroX')
install='antimicro-git.install'
-md5sums=('SKIP')
+sha512sums=('SKIP')
pkgver() {
- cd "$_name"
- git describe | sed 's/-/.r/; s/-/./'
-}
-
-
-prepare() {
- read -p '
-Use fix suggested by rakuco via AUR'"'"'s frealgagu? (Do not call QT5_WRAP_CPP.)
-> See: https://github.com/AntiMicro/antimicro/pull/207/files
-> Fix: sed -i "/QT5_WRAP_CPP/d" "${srcdir}/${_name}/CMakeLists.txt"
-[y/n]?
-' C
- [[ "$C" =~ 'y' ]] && {
- set -x;
- sed -i "/QT5_WRAP_CPP/d" "${srcdir}/${_name}/CMakeLists.txt";
- set +x;
- } || {
- echo "NOT sedding...";
- }
+ cd "${srcdir}/$_name"
+ git describe | sed 's/-/.r/; s/-/./'
}
build() {
- cd "$_name"
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DUSE_SDL_2=ON \
- -DWITH_XTEST=ON \
- -DWITH_UINPUT=ON \
- -DAPPDATA=ON
- make
+ cd "${srcdir}/$_name"
+ cmake . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DUSE_SDL_2=ON \
+ -DAPPDATA=ON \
+ -DWITH_UINPUT=ON \
+ -DWITH_X11=ON \
+ -DWITH_XTEST=ON
+ make
}
package() {
- cd "$_name"
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}/$_name"
+ make DESTDIR="$pkgdir" install
}