summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaan Kasım2015-08-12 13:44:15 +0300
committerKaan Kasım2015-08-12 13:44:15 +0300
commitf592b5eb06261c1a8f6ffce1568126ecc0d04a66 (patch)
tree3962449cd1497f999790734d54042a0d4fd773ff
downloadaur-f592b5eb06261c1a8f6ffce1568126ecc0d04a66.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD39
-rw-r--r--antimicro-git.install13
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eeaa1e2d320c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by makepkg 4.2.0
+# Fri Dec 19 14:45:31 UTC 2014
+pkgbase = antimicro-git
+ pkgdesc = Map keyboard and mouse actions to gamepad buttons, inspired by qjoypad.
+ pkgver = 2.10.r7.g4a60db4
+ pkgrel = 1
+ url = https://github.com/Ryochan7/antimicro
+ install = antimicro-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = libxtst
+ depends = qt5-base
+ depends = sdl2
+ depends = libxkbcommon-x11
+ provides = antimicro
+ conflicts = antimicro
+ source = git://github.com/Ryochan7/antimicro
+ md5sums = SKIP
+
+pkgname = antimicro-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8b4455bd9fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=antimicro-git
+pkgver=2.17.r22.ge19415e
+pkgrel=1
+
+pkgdesc='Map keyboard and mouse actions to gamepad buttons, inspired by qjoypad.'
+url='https://github.com/Ryochan7/antimicro'
+arch=('i686' 'x86_64')
+license=('GPL3')
+
+depends=('libxtst' 'qt5-base' 'sdl2')
+makedepends=('git' 'cmake' 'qt5-tools')
+
+provides=('antimicro')
+conflicts=('antimicro')
+
+source=('git://github.com/Ryochan7/antimicro')
+install='antimicro-git.install'
+
+md5sums=('SKIP')
+
+pkgver() {
+ cd antimicro
+ git describe | sed 's/-/.r/; s/-/./'
+}
+
+build() {
+ cd antimicro
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_SDL_2=ON \
+ -DWITH_XTEST=ON \
+ -DWITH_UINPUT=ON \
+ -DAPPDATA=ON
+ make
+}
+
+package() {
+ cd antimicro
+ make DESTDIR="$pkgdir" install
+}
diff --git a/antimicro-git.install b/antimicro-git.install
new file mode 100644
index 000000000000..472b4335922e
--- /dev/null
+++ b/antimicro-git.install
@@ -0,0 +1,13 @@
+post_install() {
+ xdg-icon-resource forceupdate
+ update-desktop-database -q
+ update-mime-database usr/share/mime
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}