summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrimi2015-10-13 20:24:51 +0200
committergrimi2015-10-13 20:24:51 +0200
commitb3251df40389c125df0c252e9936241914b6bb59 (patch)
tree632c6f43655ae3fc938cf86d0b183079be2c76ea
parent5591512faa121281f4a1fa364c999f163592fe08 (diff)
downloadaur-b3251df40389c125df0c252e9936241914b6bb59.tar.gz
Upstream: 2.20
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
-rw-r--r--antimicro.install12
3 files changed, 15 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ce39fecdc73..7c7addee9a63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = antimicro
pkgdesc = Graphical program used to map keyboard keys and mouse controls to gamepad buttons
- pkgver = 2.18.2
+ pkgver = 2.20
pkgrel = 1
url = https://github.com/Ryochan7/antimicro
install = antimicro.install
@@ -15,8 +15,8 @@ pkgbase = antimicro
depends = libxtst
depends = qt5-base
depends = sdl2
- source = https://github.com/Ryochan7/antimicro/archive/2.18.2.tar.gz
- md5sums = 23782c189d73aaff6d67ca60a39a0975
+ source = https://github.com/Ryochan7/antimicro/archive/2.20.tar.gz
+ md5sums = cf6ae291684155605a9b700af9371810
pkgname = antimicro
diff --git a/PKGBUILD b/PKGBUILD
index c28aabdb4088..d9cea40c6aa9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,37 +2,30 @@
# Developer: Travis Nickles <nickles.travis@gmail.com>
pkgname=antimicro
-pkgver=2.18.2
+pkgver=2.20
pkgrel=1
pkgdesc="Graphical program used to map keyboard keys and mouse controls to gamepad buttons"
arch=('i686' 'x86_64')
url="https://github.com/Ryochan7/antimicro"
license=('GPL3')
-groups=()
depends=('libxkbcommon-x11' 'libxtst' 'qt5-base' 'sdl2')
makedepends=('cmake' 'gettext' 'itstool' 'qt5-tools')
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
install="${pkgname}.install"
source=("https://github.com/Ryochan7/antimicro/archive/${pkgver}.tar.gz")
-md5sums=('23782c189d73aaff6d67ca60a39a0975')
-noextract=()
+md5sums=('cf6ae291684155605a9b700af9371810')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd ${pkgname}-${pkgver}
mkdir -p build && cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr -DUSE_SDL_2=ON -DWITH_XTEST=ON \
- -DWITH_UINPUT=ON -DAPPDATA=ON ..
- make || return 1
+ -DWITH_UINPUT=ON -DAPPDATA=ON ..
+ make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}/build"
-
+ cd ${pkgname}-${pkgver}/build
+
make DESTDIR="${pkgdir}" install
}
+
diff --git a/antimicro.install b/antimicro.install
index b5cadcc4fd7e..ad78f0bae313 100644
--- a/antimicro.install
+++ b/antimicro.install
@@ -1,16 +1,12 @@
post_install() {
- xdg-icon-resource forceupdate
+ update-mime-database usr/share/mime
+ update-desktop-database -q
}
post_upgrade() {
- post_install $1
+ post_install
}
post_remove() {
- post_install $1
+ post_install
}
-
-op=$1
-shift
-
-$op $*