summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiam Timms2022-05-24 17:17:30 -0400
committerLiam Timms2022-05-24 17:17:30 -0400
commite36d1a1f2b67ea0af9271946db91857a814ab56c (patch)
treec33e262c3a36ebed8bb1672cec2add3df1d82dd1
parentd22e4725eef49501981ca60040a0f2c5e71f9d46 (diff)
downloadaur-e36d1a1f2b67ea0af9271946db91857a814ab56c.tar.gz
updates to repo location, dependency and PKGBUILD quality guidelines
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f60d7af76cce..4a2694834273 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = ants-git
pkgdesc = Advanced Normalization Tools (ANTs) computes high-dimensional \ mappings to capture the statistics of brain structure and function
- pkgver = v2.3.5.r64.g221dad77
- pkgrel = 2
+ pkgver = 2.3.5.r126.gd30526f9
+ pkgrel = 1
url = http://www.picsl.upenn.edu/ANTS/
arch = i686
arch = x86_64
license = Apache
makedepends = git
makedepends = cmake
+ depends = libglvnd
depends = r
- depends = vtk
depends = perl
depends = gdcm
- provides = ants
+ depends = cli11
+ provides = ants=2.3.5.r126.gd30526f9
conflicts = ants
- source = ants-git::git+https://github.com/stnava/ANTs.git
+ source = ants-git::git+https://github.com/ANTsX/ANTs.git
source = 0001-fix-for-GDCM-build.patch
sha256sums = SKIP
sha256sums = f20685afed8f3fdc005b7c6924cee39350f0eac1e6010cfe9fee78a517d7e684
diff --git a/PKGBUILD b/PKGBUILD
index 8fbde9ea3e23..67ea62975ebe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,27 @@
_pkgname='ants'
pkgname="${_pkgname}-git"
-pkgver=v2.3.5.r64.g221dad77
-pkgrel=2
+pkgver=2.3.5.r126.gd30526f9
+pkgrel=1
pkgdesc='Advanced Normalization Tools (ANTs) computes high-dimensional \
mappings to capture the statistics of brain structure and function'
arch=('i686' 'x86_64')
url='http://www.picsl.upenn.edu/ANTS/'
license=('Apache')
-depends=('r' 'vtk' 'perl' 'gdcm')
+depends=('libglvnd' 'r' 'perl' 'gdcm' 'cli11')
makedepends=('git' 'cmake')
optdepends=()
-provides=("${_pkgname}")
+provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
-source=("${pkgname}"'::git+https://github.com/stnava/ANTs.git'
+source=("${pkgname}"'::git+https://github.com/ANTsX/ANTs.git'
'0001-fix-for-GDCM-build.patch')
sha256sums=('SKIP'
'f20685afed8f3fdc005b7c6924cee39350f0eac1e6010cfe9fee78a517d7e684')
pkgver() {
cd "${srcdir}/${pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ # git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {