summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2016-02-24 18:01:13 +0100
committerMichael Straube2016-02-24 18:01:13 +0100
commit9df7bb1152a5f7c4eb2e14b0e1c30e0bf8010678 (patch)
tree1f12d5ffa671b959627c72394782cf2ca105b8c7
parent9d41068e2162e94f4433d6e0f21e2f1e3195c7ba (diff)
downloadaur-9df7bb1152a5f7c4eb2e14b0e1c30e0bf8010678.tar.gz
added static library
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 856662bf3250..8b360e59107a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Feb 20 14:13:46 UTC 2016
+# Wed Feb 24 16:59:53 UTC 2016
pkgbase = anttweakbar
pkgdesc = C/C++ lib that allows programmers to quickly add a light and intuitive GUI into graphic apps to interactively tweak their params
pkgver = 1.16
@@ -12,6 +12,7 @@ pkgbase = anttweakbar
license = zlib
depends = gcc-libs
depends = glu
+ options = staticlibs
source = http://ufpr.dl.sourceforge.net/project/anttweakbar/AntTweakBar_116.zip
md5sums = 4349a13c0b5a493cf5b6b0757f3e7f0d
diff --git a/PKGBUILD b/PKGBUILD
index dacc047367a6..5b48aa2101da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,6 +9,7 @@ arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="http://anttweakbar.sourceforge.net"
license=('zlib')
depends=('gcc-libs' 'glu')
+options=('staticlibs')
source=("http://ufpr.dl.sourceforge.net/project/anttweakbar/AntTweakBar_116.zip")
md5sums=('4349a13c0b5a493cf5b6b0757f3e7f0d')
@@ -21,7 +22,13 @@ build() {
package() {
cd "AntTweakBar"
- install -Dm644 License.txt "$pkgdir/usr/share/licenses/$pkgname/License.txt"
- install -Dm755 lib/libAntTweakBar.so "${pkgdir}/usr/lib/libAntTweakBar.so"
- install -Dm644 include/AntTweakBar.h "${pkgdir}/usr/include/AntTweakBar.h"
+ install -dm755 "$pkgdir"/usr/{share/licenses/$pkgname,include,lib}
+
+ install -m644 License.txt "$pkgdir/usr/share/licenses/$pkgname/License.txt"
+ install -m644 include/AntTweakBar.h "$pkgdir/usr/include/AntTweakBar.h"
+ install -m755 lib/libAntTweakBar.so "$pkgdir/usr/lib/libAntTweakBar.so.$pkgver"
+ install -m644 lib/libAntTweakBar.a "$pkgdir/usr/lib/libAntTweakBar.a"
+
+ ln -s "libAntTweakBar.so.$pkgver" "$pkgdir/usr/lib/libAntTweakBar.so"
+ ln -s "libAntTweakBar.so.$pkgver" "$pkgdir/usr/lib/libAntTweakBar.so.1"
}