summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLara Maia2015-06-12 00:41:17 -0300
committerLara Maia2015-06-12 00:41:17 -0300
commitef76f368c55e5a35839e2264dde7a812d542c0e5 (patch)
treef7521067fc0761268b05615864430e6831901aba
downloadaur-ef76f368c55e5a35839e2264dde7a812d542c0e5.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb019255518d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = anttweakbar
+ pkgdesc = C/C++ lib that allows programmers to quickly add a light and intuitive GUI into graphic apps to interactively tweak their params
+ pkgver = 1.16
+ pkgrel = 5
+ url = http://anttweakbar.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = unzip
+ makedepends = glu
+ depends = gcc-libs
+ source = http://ufpr.dl.sourceforge.net/project/anttweakbar/AntTweakBar_116.zip
+ md5sums = 4349a13c0b5a493cf5b6b0757f3e7f0d
+
+pkgname = anttweakbar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f67d0361965
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Lara Maia <lara@craft.net.br>
+# Contributor: Zuf <kontakt.zuf@gmail.com>
+
+pkgname=anttweakbar
+pkgver=1.16
+pkgrel=5
+pkgdesc="C/C++ lib that allows programmers to quickly add a light and intuitive GUI into graphic apps to interactively tweak their params"
+arch=('i686' 'x86_64')
+url="http://anttweakbar.sourceforge.net"
+license=('custom')
+makedepends=('unzip' 'glu')
+depends=('gcc-libs')
+source=("http://ufpr.dl.sourceforge.net/project/anttweakbar/AntTweakBar_116.zip")
+md5sums=('4349a13c0b5a493cf5b6b0757f3e7f0d')
+
+build() {
+ cd "AntTweakBar"
+
+ make -C src
+}
+
+package() {
+ cd "AntTweakBar"
+
+ install -Dm644 License.txt "$pkgdir/usr/share/licenses/$pkgname/License.txt"
+ install -Dm755 lib/libAntTweakBar.so "${pkgdir}/usr/lib/libAntTweakBar.so"
+ install -Dm644 include/AntTweakBar.h "${pkgdir}/usr/include/AntTweakBar.h"
+}