summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsteelstrings2018-11-21 13:30:56 +0100
committersteelstrings2018-11-21 13:30:56 +0100
commit0f9b58436835c85ad7d5228a81f6be3684d0d17e (patch)
tree1f781c2466bb14ce0649e838585519674d2e752c
downloadaur-0f9b58436835c85ad7d5228a81f6be3684d0d17e.tar.gz
initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63a7f28960ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = antu-classic-icon-theme-git
+ pkgdesc = Antü Classic Icon Theme by Fabián Alexis
+ pkgver = 1.0.8.g90645fd
+ pkgrel = 1
+ url = https://gitlab.com/froodo_alexis/Antu-classic/
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gtk-update-icon-cache
+ provides = antu-classic-icon-theme
+ conflicts = antu-classic-icon-theme
+ source = git+https://gitlab.com/froodo_alexis/Antu-classic.git
+ sha256sums = SKIP
+
+pkgname = antu-classic-icon-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eda13860d1d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: steelstrings <steelstrings.of.a{at}gmail{dot}com>
+# based on captiva-icons-git and adwaita-icon-theme-git and antu-icon-theme-git
+
+pkgname=antu-classic-icon-theme-git
+_pkgname=Antu-classic
+pkgver=1.0.8.g90645fd
+pkgrel=1
+pkgdesc="Antü Classic Icon Theme by Fabián Alexis"
+arch=('any')
+url="https://gitlab.com/froodo_alexis/Antu-classic/"
+license=('GPL3')
+depends=('gtk-update-icon-cache')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://gitlab.com/froodo_alexis/Antu-classic.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir"/"$_pkgname"
+ git describe --long --tags| sed 's|-|.|g'
+}
+
+prepare() {
+ cd "$srcdir"/"$_pkgname" && rm {LICENSE.md,README.md}
+}
+
+package() {
+
+ # create theme dirs
+ install -d -m 755 "$pkgdir"/usr/share/icons
+
+ # install theme
+ cd "$srcdir"/"$_pkgname"/
+ cp -r . "$pkgdir"/usr/share/icons/
+}