summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIván Barcia2016-01-30 14:40:29 +0100
committerIván Barcia2016-01-30 14:40:29 +0100
commit5eb6cb8c58b2c2fd8985cfca9e2bf13d51d04a0d (patch)
tree6d6781ad1963abcd9493ee1854422979f9516be7
downloadaur-5eb6cb8c58b2c2fd8985cfca9e2bf13d51d04a0d.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..328ead506f19
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Sat Jan 30 13:40:15 UTC 2016
+pkgbase = antu-icon-theme-git
+ pkgdesc = An icon theme for Plasma Desktop
+ pkgver = r73.250ac6f
+ pkgrel = 1
+ url = https://github.com/fabianalexisinostroza/Antu-U
+ arch = any
+ license = GPL3
+ options = !strip
+ source = git+https://github.com/fabianalexisinostroza/Antu-U.git
+ sha256sums = SKIP
+
+pkgname = antu-icon-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4124ee52bb0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: barcia <barcia@opmbx.org>
+
+_gitname=Antu-U
+_pkgname=Antu
+pkgname=('antu-icon-theme-git')
+pkgver=r73.250ac6f
+pkgrel=1
+pkgdesc="An icon theme for Plasma Desktop"
+arch=('any')
+url="https://github.com/fabianalexisinostroza/${_gitname}"
+license=('GPL3')
+options=('!strip')
+conflicts=('')
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver(){
+ cd ${_gitname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -d ${pkgdir}/usr/share/icons
+ cp -r ${srcdir}/${_gitname}/${_pkgname}* ${pkgdir}/usr/share/icons/
+ find ${pkgdir}/usr -type f -exec chmod 644 {} \;
+ find ${pkgdir}/usr -type d -exec chmod 755 {} \;
+ find ${pkgdir}/usr -type f -name '.directory' -delete
+}