summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMr.Smith19742023-10-20 13:02:49 +0300
committerMr.Smith19742023-10-20 13:02:49 +0300
commit1b0160f4bd322289d2b16d94c781d2005507b77c (patch)
tree2398347b48ea806cf34c50ac7ea1386ec259360c
parenta1943f548818aa8c07073f43693e8876f0e3cbb1 (diff)
downloadaur-anura-git.tar.gz
Updated build
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD21
2 files changed, 12 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4905ebd83b6..6bee82255675 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = anura-git
pkgdesc = A fully-featured game engine, the tech behind the spectacular Frogatto & Friends.
- pkgver = 0.0.3849.gfc9853001
+ pkgver = r3950.16df0ba55
pkgrel = 1
url = https://github.com/anura-engine/anura
arch = i686
@@ -8,6 +8,7 @@ pkgbase = anura-git
license = GPL
makedepends = git
makedepends = boost
+ makedepends = glm
depends = libgl
depends = mesa
depends = glew
@@ -20,7 +21,9 @@ pkgbase = anura-git
depends = boost-libs
optdepends = frogatto-git: the default game module
optdepends = box2d: box2d physics
- source = git+https://github.com/anura-engine/anura.git#branch=buildsystem-upgrade
+ provides = anura=r3950.16df0ba55
+ conflicts = anura
+ source = git+https://github.com/anura-engine/anura.git
source = git+https://github.com/sweetkristas/imgui.git
source = anura.sh
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index aa30c37f4ed0..6b48e35ec562 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Yaohan Chen <yaohan.chen@gmail.com>
pkgname=anura-git
-pkgver=0.0.3849.gfc9853001
+pkgver=r3950.16df0ba55
pkgrel=1
pkgdesc="A fully-featured game engine, the tech behind the spectacular Frogatto & Friends."
arch=(i686 x86_64)
@@ -9,8 +9,10 @@ license=('GPL')
depends=(libgl mesa glew cairo sdl2 sdl2_image sdl2_ttf sdl2_mixer libpng boost-libs)
optdepends=('frogatto-git: the default game module'
'box2d: box2d physics')
-makedepends=(git boost)
-source=('git+https://github.com/anura-engine/anura.git#branch=buildsystem-upgrade'
+makedepends=('git' 'boost' 'glm')
+provides=("anura=$pkgver")
+conflicts=('anura')
+source=('git+https://github.com/anura-engine/anura.git'
'git+https://github.com/sweetkristas/imgui.git'
anura.sh)
md5sums=('SKIP'
@@ -23,19 +25,12 @@ prepare() {
cd $_gitname
git submodule init
git config submodule.imgui.url "$srcdir/imgui"
- git submodule update
+ git -c protocol.file.allow=always submodule update
}
pkgver() {
cd $_gitname
- if _tag=$(git describe 2>/dev/null)
- then
- # Use the tag of the last commit
- echo $_tag | sed 's|-|.|g'
- else
- # The project currently has no tags yet
- echo 0.0.$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)
- fi
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
@@ -58,5 +53,3 @@ package() {
cp -r music $_installdir
cp -r modules $_installdir
}
-
-# vim:set ts=2 sw=2 et: