summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYaohan Chen2019-10-31 03:04:45 -0400
committerYaohan Chen2019-10-31 03:08:21 -0400
commit2a95caac36b4066bbeaeb8d21d1a75cef71401f8 (patch)
tree89423243703020dc1c8f31043e1f2139b4eb5b10
parentad0fdbafc91ae61a827339779b0a1714579d9fc4 (diff)
downloadaur-2a95caac36b4066bbeaeb8d21d1a75cef71401f8.tar.gz
Remove merged patches
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD13
-rw-r--r--fix_boost_uuid_detail_sha1_path.patch26
-rw-r--r--fix_redefine_have_m_pi_error.patch26
5 files changed, 6 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9e15a1fc5a1..8e71614c476a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = anura-git
pkgdesc = A fully-featured game engine, the tech behind the spectacular Frogatto & Friends.
- pkgver = 0.0.3603.gd8e7ff8a
+ pkgver = 0.0.3619.ge4a2f2e7
pkgrel = 1
url = https://github.com/anura-engine/anura
install = anura.install
@@ -24,13 +24,9 @@ pkgbase = anura-git
source = git+https://github.com/anura-engine/anura.git#branch=trunk
source = git+https://github.com/sweetkristas/imgui.git
source = anura.sh
- source = fix_redefine_have_m_pi_error.patch
- source = fix_boost_uuid_detail_sha1_path.patch
md5sums = SKIP
md5sums = SKIP
md5sums = 15f4c03c2404bcfd7618b8f9e0c850ba
- md5sums = bfdf31856d06c69ef13ee76f0a67242b
- md5sums = 6a929113d76065841c1cb87bf4798f58
pkgname = anura-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f34a96c51ab9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
index a4f39cc9f1dc..b0f9ebb425a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Yaohan Chen <yaohan.chen@gmail.com>
pkgname=anura-git
-pkgver=0.0.3603.gd8e7ff8a
+pkgver=0.0.3619.ge4a2f2e7
pkgrel=1
pkgdesc="A fully-featured game engine, the tech behind the spectacular Frogatto & Friends."
arch=(i686 x86_64)
@@ -12,14 +12,10 @@ optdepends=('frogatto-git: the default game module'
makedepends=(git boost)
source=('git+https://github.com/anura-engine/anura.git#branch=trunk'
'git+https://github.com/sweetkristas/imgui.git'
- anura.sh
- fix_redefine_have_m_pi_error.patch
- fix_boost_uuid_detail_sha1_path.patch)
+ anura.sh)
md5sums=('SKIP'
'SKIP'
- '15f4c03c2404bcfd7618b8f9e0c850ba'
- 'bfdf31856d06c69ef13ee76f0a67242b'
- '6a929113d76065841c1cb87bf4798f58')
+ '15f4c03c2404bcfd7618b8f9e0c850ba')
install=anura.install
_gitname=anura
@@ -29,9 +25,6 @@ prepare() {
git submodule init
git config submodule.imgui.url "$srcdir/imgui"
git submodule update
-
- git apply "$srcdir/fix_redefine_have_m_pi_error.patch"
- git apply "$srcdir/fix_boost_uuid_detail_sha1_path.patch"
}
pkgver() {
diff --git a/fix_boost_uuid_detail_sha1_path.patch b/fix_boost_uuid_detail_sha1_path.patch
deleted file mode 100644
index 415a171f505a..000000000000
--- a/fix_boost_uuid_detail_sha1_path.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/src/formula_function.cpp b/src/formula_function.cpp
-index 6ad07c92..40ccb0b8 100644
---- a/src/formula_function.cpp
-+++ b/src/formula_function.cpp
-@@ -28,7 +28,7 @@
-
- #include <boost/format.hpp>
- #include <boost/lexical_cast.hpp>
--#include <boost/uuid/sha1.hpp>
-+#include <boost/uuid/detail/sha1.hpp>
- #include <boost/algorithm/string.hpp>
- #include <boost/exception/diagnostic_information.hpp>
- #include <boost/exception_ptr.hpp>
-diff --git a/src/preferences.cpp b/src/preferences.cpp
-index d8a0cbbd..3c4afcb2 100644
---- a/src/preferences.cpp
-+++ b/src/preferences.cpp
-@@ -28,7 +28,7 @@
-
- #include <boost/regex.hpp>
- #include <boost/lexical_cast.hpp>
--#include <boost/uuid/sha1.hpp>
-+#include <boost/uuid/detail/sha1.hpp>
-
- #include "asserts.hpp"
- #include "controls.hpp"
diff --git a/fix_redefine_have_m_pi_error.patch b/fix_redefine_have_m_pi_error.patch
deleted file mode 100644
index f852248f6001..000000000000
--- a/fix_redefine_have_m_pi_error.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/src/kre/SurfaceSDL.cpp b/src/kre/SurfaceSDL.cpp
-index 6eda12ee..34f61b7c 100644
---- a/src/kre/SurfaceSDL.cpp
-+++ b/src/kre/SurfaceSDL.cpp
-@@ -24,9 +24,6 @@
- #ifndef _USE_MATH_DEFINES
- # define _USE_MATH_DEFINES 1
- #endif
--#ifndef HAVE_M_PI
--# define HAVE_M_PI
--#endif
-
- #include "SDL_image.h"
-
-diff --git a/src/tiled/tiled.cpp b/src/tiled/tiled.cpp
-index 0812ed77..06e56288 100644
---- a/src/tiled/tiled.cpp
-+++ b/src/tiled/tiled.cpp
-@@ -21,7 +21,6 @@
- distribution.
- */
-
--#define HAVE_M_PI
- #include "SDL.h"
- #include "SDL_image.h"
-