summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Xhokaxhiu2017-04-24 22:53:58 +0200
committerJulian Xhokaxhiu2017-04-24 22:53:58 +0200
commit9b36ab7adada82c2f92673d49c40b6fc04afc174 (patch)
tree388dec3c262fb8b3072310088bf6af49e9b46227
downloadaur-9b36ab7adada82c2f92673d49c40b6fc04afc174.tar.gz
First version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1145ed96ff5c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = any-proxy-git
+ pkgdesc = A transparent proxy written in Golang
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/julianxhokaxhiu/go-any-proxy
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = go
+ makedepends = git
+ source = https://github.com/julianxhokaxhiu/go-any-proxy.git
+ md5sums = SKIP
+
+pkgname = any-proxy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be484277b55a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Julian Xhokaxhiu <info@julianxhokaxhiu.com>
+pkgname=any-proxy-git
+pkgver=1.2
+pkgrel=1
+pkgdesc="A transparent proxy written in Golang"
+url="https://github.com/julianxhokaxhiu/go-any-proxy"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('MIT')
+makedepends=('go' 'git')
+source=("https://github.com/julianxhokaxhiu/go-any-proxy.git")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/go-any-proxy"
+
+ ./make.bash
+}
+
+package() {
+ cd "$srcdir/go-any-proxy"
+
+ #Install binaries
+ install -Dm755 any_proxy "$pkgdir/usr/bin/any_proxy"
+}