summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Jaksch2018-07-18 11:16:35 +0200
committerOliver Jaksch2018-07-18 11:16:35 +0200
commit8ed360dd4777a1b2db6e9288075b7424bfd0e3ae (patch)
tree1f7a9d7639f6eb59657abda8ab5b7ca40549d47c
parent841ed03154744166af90585424557dc41780ae49 (diff)
downloadaur-8ed360dd4777a1b2db6e9288075b7424bfd0e3ae.tar.gz
Fixed a dep
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9346d7067350..50ffc31e3335 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Wed Jul 18 09:05:23 UTC 2018
-pkgbase = anydesk-test
- pkgdesc = 'AnyDesk Free' is an All-In-One Software for Remote Support - Playground-Version
+# Wed Jul 18 09:16:34 UTC 2018
+pkgbase = anydesk
+ pkgdesc = 'AnyDesk Free' is an All-In-One Software for Remote Support
pkgver = 2.9.7
- pkgrel = 1
+ pkgrel = 2
url = https://anydesk.de
arch = i686
arch = x86_64
license = custom:Freeware
depends = fakeroot
+ depends = python-shiboken2
depends = gtkglext
depends = libglvnd
depends = gtk2
@@ -27,15 +28,11 @@ pkgbase = anydesk-test
depends = libxdamage
depends = gcc-libs
optdepends = libpulse
- conflicts = anydesk
+ conflicts = anydesk-test
source_i686 = http://download.anydesk.com/linux/anydesk_2.9.7-1_i386.deb
- source_i686 = https://download.anydesk.com/linux/anydesk-2.9.7-i686.tar.gz
sha256sums_i686 = a2d0e3d781fd5392c158181513f46dc51ad88394d8ab93c475f85bffa2d399fa
- sha256sums_i686 = f4c7b2bcc4932594cfd8b656a2e3f7a63dab1423bab54b16b06903f2910618f6
source_x86_64 = http://download.anydesk.com/linux/anydesk_2.9.7-1_amd64.deb
- source_x86_64 = https://download.anydesk.com/linux/anydesk-2.9.7-amd64.tar.gz
sha256sums_x86_64 = edc4fc763ae14a0e103bfa6df89e999aaa246c908b80fe12ecbbe9f9bfe0c890
- sha256sums_x86_64 = 8eeed35500b168fa5d0e0a04523466f9874c47bdb491fdededb651783fe7afa8
-pkgname = anydesk-test
+pkgname = anydesk
diff --git a/PKGBUILD b/PKGBUILD
index 74f4966744b7..cb264664a63e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
# Maintainer: Oliver Jaksch <arch-aur@com-in.de>
-pkgname=anydesk-test
+pkgname=anydesk
pkgver=2.9.7
-pkgrel=1
-pkgdesc="'AnyDesk Free' is an All-In-One Software for Remote Support - Playground-Version"
+pkgrel=2
+pkgdesc="'AnyDesk Free' is an All-In-One Software for Remote Support"
arch=('i686' 'x86_64')
url="https://anydesk.de"
license=('custom:Freeware')
-depends=('fakeroot' 'gtkglext' 'libglvnd' 'gtk2' 'libx11' 'glibc' 'glib2' 'gdk-pixbuf2' 'libxcb' 'cairo' 'pango' 'libxi' 'libxrandr' 'libxtst' 'libxext' 'libxfixes' 'libxdamage' 'gcc-libs')
+depends=('fakeroot' 'python-shiboken2' 'gtkglext' 'libglvnd' 'gtk2' 'libx11' 'glibc' 'glib2' 'gdk-pixbuf2' 'libxcb' 'cairo' 'pango' 'libxi' 'libxrandr' 'libxtst' 'libxext' 'libxfixes' 'libxdamage' 'gcc-libs')
optdepends=('libpulse')
-conflicts=('anydesk')
+conflicts=('anydesk-test')
-source_i686=("http://download.anydesk.com/linux/anydesk_${pkgver}-1_i386.deb" "https://download.anydesk.com/linux/anydesk-${pkgver}-i686.tar.gz")
-source_x86_64=("http://download.anydesk.com/linux/anydesk_${pkgver}-1_amd64.deb" "https://download.anydesk.com/linux/anydesk-${pkgver}-amd64.tar.gz")
+source_i686=(http://download.anydesk.com/linux/${pkgname}_${pkgver}-1_i386.deb)
+source_x86_64=(http://download.anydesk.com/linux/${pkgname}_${pkgver}-1_amd64.deb)
-sha256sums_i686=('a2d0e3d781fd5392c158181513f46dc51ad88394d8ab93c475f85bffa2d399fa' 'f4c7b2bcc4932594cfd8b656a2e3f7a63dab1423bab54b16b06903f2910618f6')
-sha256sums_x86_64=('edc4fc763ae14a0e103bfa6df89e999aaa246c908b80fe12ecbbe9f9bfe0c890' '8eeed35500b168fa5d0e0a04523466f9874c47bdb491fdededb651783fe7afa8')
+sha256sums_i686=('a2d0e3d781fd5392c158181513f46dc51ad88394d8ab93c475f85bffa2d399fa')
+sha256sums_x86_64=('edc4fc763ae14a0e103bfa6df89e999aaa246c908b80fe12ecbbe9f9bfe0c890')
package() {
cd "${pkgdir}"
tar xf "${srcdir}/data.tar.gz"
- install -m755 "${srcdir}/anydesk-${pkgver}/anydesk" "${pkgdir}/usr/bin/anydesk"
#
msg2 "\e[1;32mAnyDesk now has a systemd file for unattendant access: anydesk.service \e[0m"
install -D -m 644 "${pkgdir}/usr/share/anydesk/files/systemd/anydesk.service" "${pkgdir}/usr/lib/systemd/system/anydesk.service"