summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Jaksch2018-07-18 10:48:20 +0200
committerOliver Jaksch2018-07-18 10:48:20 +0200
commitb8a07ca52da360f567d1e795ab7df2fe43f42123 (patch)
tree6b8ed655e7822677f1cadffa07c36cb2e2e77a31
parent9dcf9854904f4232c2f52598e1c0c50345ada1bb (diff)
downloadaur-b8a07ca52da360f567d1e795ab7df2fe43f42123.tar.gz
Update to 2.9.7
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a7d240c35bb..4dfbd988f9e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Fri Jun 15 09:30:20 UTC 2018
+# Wed Jul 18 08:48:20 UTC 2018
pkgbase = anydesk
pkgdesc = 'AnyDesk Free' is an All-In-One Software for Remote Support
- pkgver = 2.9.6
+ pkgver = 2.9.7
pkgrel = 1
- url = http://anydesk.de/
+ url = https://anydesk.de
arch = i686
arch = x86_64
license = custom:Freeware
@@ -27,10 +27,11 @@ pkgbase = anydesk
depends = libxdamage
depends = gcc-libs
optdepends = libpulse
- source_i686 = http://download.anydesk.com/linux/anydesk_2.9.6-1_i386.deb
- sha256sums_i686 = 7a023315b63ef5ca99011eb7ce718ebd79c42852db5ee67a8f257f617799ff41
- source_x86_64 = http://download.anydesk.com/linux/anydesk_2.9.6-1_amd64.deb
- sha256sums_x86_64 = 0ced2e3d26f86a4d9586d38d56f4818bde05c79c317291c1db1503e878c1dc44
+ conflicts = anydesk-test
+ source_i686 = http://download.anydesk.com/linux/anydesk_2.9.7-1_i386.deb
+ sha256sums_i686 = a2d0e3d781fd5392c158181513f46dc51ad88394d8ab93c475f85bffa2d399fa
+ source_x86_64 = http://download.anydesk.com/linux/anydesk_2.9.7-1_amd64.deb
+ sha256sums_x86_64 = edc4fc763ae14a0e103bfa6df89e999aaa246c908b80fe12ecbbe9f9bfe0c890
pkgname = anydesk
diff --git a/PKGBUILD b/PKGBUILD
index 07c5c6dc09e6..bd2c4cdb6ca2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
# Maintainer: Oliver Jaksch <arch-aur@com-in.de>
pkgname=anydesk
-pkgver=2.9.6
+pkgver=2.9.7
pkgrel=1
pkgdesc="'AnyDesk Free' is an All-In-One Software for Remote Support"
arch=('i686' 'x86_64')
-url="http://anydesk.de/"
+url="https://anydesk.de"
license=('custom:Freeware')
depends=('fakeroot' 'gtkglext' 'libglvnd' 'gtk2' 'libx11' 'glibc' 'glib2' 'gdk-pixbuf2' 'libxcb' 'cairo' 'pango' 'libxi' 'libxrandr' 'libxtst' 'libxext' 'libxfixes' 'libxdamage' 'gcc-libs')
optdepends=('libpulse')
+conflicts=('anydesk-test')
source_i686=(http://download.anydesk.com/linux/${pkgname}_${pkgver}-1_i386.deb)
source_x86_64=(http://download.anydesk.com/linux/${pkgname}_${pkgver}-1_amd64.deb)
-sha256sums_i686=('7a023315b63ef5ca99011eb7ce718ebd79c42852db5ee67a8f257f617799ff41')
-sha256sums_x86_64=('0ced2e3d26f86a4d9586d38d56f4818bde05c79c317291c1db1503e878c1dc44')
+sha256sums_i686=('a2d0e3d781fd5392c158181513f46dc51ad88394d8ab93c475f85bffa2d399fa')
+sha256sums_x86_64=('edc4fc763ae14a0e103bfa6df89e999aaa246c908b80fe12ecbbe9f9bfe0c890')
package() {
cd "${pkgdir}"
tar xf "${srcdir}/data.tar.gz"
#
- msg2 "\e[1;32mIf you want to enable the autostart mode, edit PKGBUILD and comment line #24 \e[0m"
- rm -rf etc/
+ msg2 "\e[1;32mAnyDesk now has a systemd file for unattendant access: anydesk.service \e[0m"
+ install -D -m 644 "${pkgdir}/usr/share/anydesk/files/systemd/anydesk.service" "${pkgdir}/usr/lib/systemd/system/anydesk.service"
+ sed -i "s/PIDFile=\/tm\/ad.pid/PIDFile=\/run\/anydesk.pid/" "${pkgdir}/usr/lib/systemd/system/anydesk.service"
}