summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Jaksch2020-01-08 13:39:11 +0100
committerOliver Jaksch2020-01-08 13:39:11 +0100
commitc31e81075aee4723cdd39666cc2f5921a0354c7e (patch)
tree342c58c7a25bdf0a4f2ab4e068512eda4c25dcdc
parent92b42852db5e437302204dfe1e214c13afd1afb6 (diff)
downloadaur-c31e81075aee4723cdd39666cc2f5921a0354c7e.tar.gz
Fix for issues with newer pango - contains a binary blob for now
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--PKGBUILD.pango42
-rwxr-xr-xanydesk.sh3
-rw-r--r--pango-1.43.0-2.tar.gzbin0 -> 197078 bytes
5 files changed, 60 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78f73c84ffb5..2d5dc91ea16d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = anydesk
pkgdesc = 'AnyDesk Free' is an All-In-One Software for Remote Support
pkgver = 5.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://anydesk.de
arch = i686
arch = x86_64
@@ -27,6 +27,12 @@ pkgbase = anydesk
depends = gcc-libs
optdepends = libpulse
conflicts = anydesk-test
+ source = anydesk.sh
+ source = PKGBUILD.pango
+ source = pango-1.43.0-2.tar.gz
+ sha256sums = 2368b0011fc52cbb4cf8013436628d25db3a86b35ae9a04868e221656a0f77a3
+ sha256sums = f73e451632a1297acba18feb33a1871d532f65640ea59c10ca59152a80034d44
+ sha256sums = a5c9b0530ef5ddb571be4236a8ba624a78ab048fa9be34d135b269052b0459cf
source_i686 = https://download.anydesk.com/linux/anydesk_5.5.1-1_i386.deb
sha256sums_i686 = 0587765e713c8a6a2e59977f0aaed3b2425753a26656df5a5ed69b9e94f6eac1
source_x86_64 = https://download.anydesk.com/linux/anydesk_5.5.1-1_amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index b1df24c17bf1..50a2620a58c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=anydesk
pkgver=5.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="'AnyDesk Free' is an All-In-One Software for Remote Support"
arch=('i686' 'x86_64')
url="https://anydesk.de"
@@ -13,9 +13,11 @@ conflicts=('anydesk-test')
source_i686=(https://download.anydesk.com/linux/${pkgname}_${pkgver}-1_i386.deb)
source_x86_64=(https://download.anydesk.com/linux/${pkgname}_${pkgver}-1_amd64.deb)
+source=('anydesk.sh' 'PKGBUILD.pango' 'pango-1.43.0-2.tar.gz')
sha256sums_i686=('0587765e713c8a6a2e59977f0aaed3b2425753a26656df5a5ed69b9e94f6eac1')
sha256sums_x86_64=('17d1dacde77730a84b5acd2f5dbf588638d7a78655cb8256a689479369330440')
+sha256sums=('2368b0011fc52cbb4cf8013436628d25db3a86b35ae9a04868e221656a0f77a3' 'f73e451632a1297acba18feb33a1871d532f65640ea59c10ca59152a80034d44' 'a5c9b0530ef5ddb571be4236a8ba624a78ab048fa9be34d135b269052b0459cf')
package() {
cd "${pkgdir}"
@@ -24,6 +26,11 @@ package() {
# temporary fix for wrong permissions on subdirs:
find "${pkgdir}" -type d -exec chmod 755 {} \;
#
+ # temporary fix for issues with pango>=1.44
+ install "${pkgdir}/usr/bin/anydesk" "${pkgdir}/usr/bin/anydesk.bin"
+ install "${srcdir}/anydesk.sh" "${pkgdir}/usr/bin/anydesk"
+ cp -r "${srcdir}/pango-1.43.0-2" "${pkgdir}/usr/share/anydesk/files"
+ #
msg2 "\e[1;32mAnyDesk now has a systemd file for unattendant access: anydesk.service \e[0m"
install -D -m 644 "${pkgdir}/usr/share/anydesk/files/systemd/anydesk.service" "${pkgdir}/usr/lib/systemd/system/anydesk.service"
sed -i "s/PIDFile=\/tm\/ad.pid/PIDFile=\/run\/anydesk.pid/" "${pkgdir}/usr/lib/systemd/system/anydesk.service"
diff --git a/PKGBUILD.pango b/PKGBUILD.pango
new file mode 100644
index 000000000000..aca4ba721935
--- /dev/null
+++ b/PKGBUILD.pango
@@ -0,0 +1,42 @@
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=pango
+pkgver=1.43.0
+pkgrel=2
+epoch=1
+pkgdesc="A library for layout and rendering of text"
+url="https://www.pango.org/"
+arch=(x86_64)
+license=(LGPL)
+depends=(libthai cairo libxft harfbuzz fribidi)
+makedepends=(gobject-introspection help2man gtk-doc git meson)
+checkdepends=(ttf-dejavu cantarell-fonts)
+_commit=26f1135f374f3ad5eb963dcdf016542fbbda361b # tags/1.43.0^0
+source=("git+https://gitlab.gnome.org/GNOME/pango.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd pango
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd pango
+
+ # Fix .pc
+ git cherry-pick -n d0cb6be7431d1a3c711bd45bcf05b34601604037
+}
+
+build() {
+ arch-meson pango build -D enable_docs=true
+ ninja -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+ rm -r "$pkgdir"/usr/{lib,share}/installed-tests
+}
diff --git a/anydesk.sh b/anydesk.sh
new file mode 100755
index 000000000000..13b918f43a23
--- /dev/null
+++ b/anydesk.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/share/anydesk/files/pango-1.43.0-2 /usr/bin/anydesk.bin $@
diff --git a/pango-1.43.0-2.tar.gz b/pango-1.43.0-2.tar.gz
new file mode 100644
index 000000000000..d31bf2d28b89
--- /dev/null
+++ b/pango-1.43.0-2.tar.gz
Binary files differ