summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDX372019-03-11 15:33:47 +0700
committerDX372019-03-11 15:33:47 +0700
commit61fb9b475217f25bc649137d5ab82f8585b26d5c (patch)
treef901bd8fe0d4a2831f5220dfbf9e5d0f3af09271
downloadaur-61fb9b475217f25bc649137d5ab82f8585b26d5c.tar.gz
anylogic-ple pkg repo init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
-rw-r--r--executable.patch8
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e94cae81ed03
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = anylogic-ple
+ pkgdesc = AnyLogic Personal Learning Edition - for beginners and students
+ pkgver = 8.4.0
+ pkgrel = 1
+ url = https://www.anylogic.com
+ arch = x86_64
+ license = custom
+ noextract = $pkgname-$pkgver.linux.x86_64.tgz.bin
+ options = !strip
+ source = https://files.anylogic.com/anylogic-ple-8.4.0.linux.x86_64.tgz.bin
+ source = executable.patch
+ sha256sums = 40d7439aef966965fbdd0840d091ea582ddda85c09ef4deea582af7728a8cfad
+ sha256sums = 07c96e32b20a9d7c2c6926d261de442fc323bf82e427b0f78eeab00a79e97f7d
+
+pkgname = anylogic-ple
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f6fc166bff8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Maxim Kurnosenko <asusx2@mail.ru>
+
+pkgname=anylogic-ple
+pkgver=8.4.0
+pkgrel=1
+pkgdesc="AnyLogic Personal Learning Edition - for beginners and students"
+arch=(x86_64)
+url="https://www.anylogic.com"
+license=('custom')
+options=(!strip)
+source=("https://files.anylogic.com/$pkgname-$pkgver.linux.x86_64.tgz.bin"
+ "executable.patch")
+noextract=('$pkgname-$pkgver.linux.x86_64.tgz.bin')
+sha256sums=('40d7439aef966965fbdd0840d091ea582ddda85c09ef4deea582af7728a8cfad'
+ '07c96e32b20a9d7c2c6926d261de442fc323bf82e427b0f78eeab00a79e97f7d')
+
+prepare() {
+ msg2 "Unpacking archive..."
+ tail -n +347 "$srcdir/$pkgname-$pkgver.linux.x86_64.tgz.bin" > "$pkgname-$pkgver.linux.x86_64.tgz"
+ msg2 "Extracting archive..."
+ tar -xf $pkgname-$pkgver.linux.x86_64.tgz
+}
+
+package() {
+ mkdir -p "$pkgdir/opt"
+
+ msg2 "Copying AnyLogic contents..."
+ cp -R "$srcdir/anylogic" "$pkgdir/opt"
+ msg2 "Copy AnyLogic start script..."
+ install -Dm755 "$srcdir/anylogic/start-anylogic.sh" "$pkgdir/usr/bin/anylogic"
+ msg2 "Patching AnyLogic start script..."
+ patch -i "$srcdir/executable.patch" "$pkgdir/usr/bin/anylogic"
+
+ install -Dm644 "$srcdir/anylogic/license/Software Licensing Agreement for AnyLogic.txt" "$pkgdir/usr/share/licenses/anylogic/LICENSE"
+}
diff --git a/executable.patch b/executable.patch
new file mode 100644
index 000000000000..a21fcd4e7a48
--- /dev/null
+++ b/executable.patch
@@ -0,0 +1,8 @@
+--- start-anylogic.sh 2019-03-11 14:14:40.733870703 +0700
++++ anylogic 2019-03-11 14:15:14.762279318 +0700
+@@ -1,3 +1,3 @@
+ #!/bin/sh
+
+-SWT_GTK3=0 UBUNTU_MENUPROXY= ./anylogic
+\ No newline at end of file
++SWT_GTK3=0 UBUNTU_MENUPROXY= /opt/anylogic/anylogic