summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-07 07:38:34 +1300
committercaltlgin2020-10-07 07:38:34 +1300
commitd63c104040b80bb8e162116598ab16aaacc94e79 (patch)
tree38ac684fe63a14a93406aa78d42ad69100af9a75
downloadaur-d63c104040b80bb8e162116598ab16aaacc94e79.tar.gz
Add to AUR
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd968a2080c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = anymeal-git
+ pkgdesc = Recipe Management Software
+ pkgver = 1.8.r1.g1535c12
+ pkgrel = 1
+ url = https://wedesoft.github.io/anymeal/
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = gtest
+ makedepends = qt5-tools
+ depends = hicolor-icon-theme
+ depends = qt5-base
+ depends = recode
+ provides = anymeal
+ conflicts = anymeal
+ source = git+https://github.com/wedesoft/anymeal.git
+ sha256sums = SKIP
+
+pkgname = anymeal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85b1198bfd90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname='anymeal'
+pkgname="${_pkgname}-git"
+pkgver=1.8.r1.g1535c12
+pkgrel=1
+pkgdesc='Recipe Management Software'
+arch=('x86_64')
+url='https://wedesoft.github.io/anymeal/'
+_url_source='https://github.com/wedesoft/anymeal'
+license=('GPL3')
+depends=('hicolor-icon-theme' 'qt5-base' 'recode')
+makedepends=('git' 'gtest' 'qt5-tools')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+${_url_source}.git")
+sha256sums=('SKIP')
+
+prepare() {
+ # Fix Googletest file path
+ sed -i.bak "24s|googletest/googletest|googletest|" "${_pkgname}/configure.ac"
+}
+
+pkgver() {
+ git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${_pkgname}"
+ autoreconf --install
+ ./configure --prefix=/usr
+}
+
+package() {
+ make DESTDIR="${pkgdir}" -C "${_pkgname}" install
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" "${_pkgname}/README.md"
+}
+
+# vim: ts=2 sw=2 et: