aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJul Lang2025-03-22 14:08:04 +0100
committerJul Lang2025-03-22 14:08:11 +0100
commit3976cd8627ab408f4a3e282d88202ef019df9e3d (patch)
tree965c714c8286ec929c0895b826b6c8500e1b9c45
parent5c7f83343b0cff3629f413de482d6d2ab8c9f183 (diff)
downloadaur-3976cd8627ab408f4a3e282d88202ef019df9e3d.tar.gz
use inline desktop file
-rw-r--r--PKGBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c1a8b14b8ce..4942610634bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,8 +28,20 @@ build() {
package() {
# Desktop file
- install -Dm644 "$srcdir/squashfs-root/$pkgname.desktop" \
- "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 /dev/stdin "$pkgdir/usr/share/applications/$pkgname.desktop" <<EOF
+[Desktop Entry]
+Version=$pkgver
+Type=Application
+Name=$_PkgName
+GenericName=$_PkgName
+Comment=$pkgdesc
+Exec=$pkgname
+Icon=$pkgname
+Terminal=false
+Categories=Utility;Application;
+Keywords=$pkgname;anime
+StartupNotify=true
+EOF
# Icon images
mkdir -p "$pkgdir/usr/share/"