summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Fagiani2015-06-08 18:19:43 +0200
committerAndrea Fagiani2015-06-08 18:19:43 +0200
commit93aecb3ea8a29418707d67df6f445304be8957cc (patch)
tree05a83e593fd958ee2f764ebe6c7d828d66ea90e3
downloadaur-93aecb3ea8a29418707d67df6f445304be8957cc.tar.gz
AUR4 Import + update to 6.5
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
-rw-r--r--anyremote.install6
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb420e6a3658
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = anyremote
+ pkgdesc = Remote control (console-oriented) through bluetooth or IR connection
+ pkgver = 6.4
+ pkgrel = 1
+ url = http://anyremote.sourceforge.net
+ install = anyremote.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = bluez-libs
+ depends = bluez
+ depends = dbus-glib
+ depends = libxtst
+ optdepends = irda-utils: IRDA support
+ source = http://downloads.sourceforge.net/sourceforge/anyremote/anyremote-6.4.tar.gz
+ md5sums = 050d5625e97b5844e10c83efdb7abc51
+
+pkgname = anyremote
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e0426ece51c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Andrea Fagiani <andfagiani_at_gmail_dot_com>
+# Contributor: hb <hb.at.spamers.dot.net>
+# Contributor: Lisa Denia <eiffel56@gmail.com>
+
+pkgname=anyremote
+pkgver=6.5
+pkgrel=1
+pkgdesc="Remote control (console-oriented) through bluetooth or IR connection"
+arch=('i686' 'x86_64')
+url="http://anyremote.sourceforge.net"
+license=('GPL')
+depends=('bluez-libs' 'bluez' 'dbus-glib' 'libxtst')
+optdepends=("irda-utils: IRDA support")
+install=anyremote.install
+source=(http://downloads.sourceforge.net/sourceforge/anyremote/$pkgname-$pkgver.tar.gz)
+md5sums=('2ebd8d41b2a525e186bd9a3199896fec')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}
diff --git a/anyremote.install b/anyremote.install
new file mode 100644
index 000000000000..012444ce0234
--- /dev/null
+++ b/anyremote.install
@@ -0,0 +1,6 @@
+post_install () {
+ echo "
+ >>>Download the java client for your phone at
+ >>>http://anyremote.sourceforge.net/dload.html
+ "
+}