summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirottu2024-04-03 15:47:37 +0300
committerKirottu2024-04-03 15:47:37 +0300
commit16991251509f8a97d573b79f1740bc4eb930a004 (patch)
tree11d58d99f75f37382a7460de18ce4dd2259ada59
downloadaur-anyrun-plugin-translate.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
-rw-r--r--v0.1.0.tar.gzbin0 -> 26335 bytes
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1007e15c2743
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = anyrun-plugin-translate
+ pkgdesc = Translate plugin for quick text translation.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/anyrun-org/plugin-translate
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cargo
+ depends = anyrun
+ source = https://github.com/anyrun-org/plugin-translate/archive/refs/tags/v0.1.0.tar.gz
+ sha256sums = 9609ce9a42999bc17a99049efa73595fac93a4de39b4308746814775b6bbaa8e
+
+pkgname = anyrun-plugin-translate
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f5a1614eba6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: KirottuM <arnovaara@gmail.com>
+pkgname="anyrun-plugin-translate"
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Translate plugin for quick text translation."
+arch=("x86_64")
+url="https://github.com/anyrun-org/plugin-translate"
+license=('GPL3')
+depends=(anyrun)
+makedepends=(git cargo)
+source=("https://github.com/anyrun-org/plugin-translate/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('9609ce9a42999bc17a99049efa73595fac93a4de39b4308746814775b6bbaa8e')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ export RUSTUP_TOOLCHAIN=stable
+ install -Dm0644 -t "$pkgdir/etc/anyrun/plugins/" "target/release/libtranslate.so"
+}
diff --git a/v0.1.0.tar.gz b/v0.1.0.tar.gz
new file mode 100644
index 000000000000..421aa6d3d493
--- /dev/null
+++ b/v0.1.0.tar.gz
Binary files differ