aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Maximiliano Marino2021-07-24 10:52:35 +0300
committerLucas Maximiliano Marino2021-07-24 10:52:35 +0300
commita5c9afdd8d6183f7b5f94252c7007603339623ae (patch)
tree72a6f33d42d61be8ba73b271fe1201333f32a23e
downloadaur-a5c9afdd8d6183f7b5f94252c7007603339623ae.tar.gz
feat: initial commit with fully working script
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore17
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD31
-rw-r--r--README.md38
-rw-r--r--anytype.desktop10
-rw-r--r--anytype.pngbin0 -> 28602 bytes
7 files changed, 137 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a49071673d73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = anytype-bin
+ pkgdesc = Operating environment for the new internet. Anytype is a next generation software that breaks down barriers between applications, gives back privacy and data ownership to users.
+ pkgver = 0.18.51
+ pkgrel = 1
+ url = https://anytype.io/
+ arch = x86_64
+ license = custom
+ depends = fuse
+ provides = anytype
+ conflicts = anytype
+ noextract = Anytype-0.18.51.AppImage
+ options = !strip
+ source = Anytype-0.18.51.AppImage::https://download.anytype.io/?action=download&id=40825766
+ source = anytype.desktop
+ source = anytype.png
+ sha256sums = 572b2bc3fa183d924ebf2d5ad25a3e79cadf0d808ac1c4455469a55e9dbad0f4
+ sha256sums = 1bda1398291bed84ebee1d2c3e94b4c367925a8e2c0bd371aba8d6604e54281f
+ sha256sums = 48ee23a45c29cf081ccf5188c045150b7410007cd21743ce8592974ab18120c0
+
+pkgname = anytype-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a95e2d02876a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+*.AppImage
+anytype-appimage-*.pkg.tar.zst
+anytype-appimage-*.log
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..6e571f4ff1c6
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2021 Lucas Maximiliano Marino
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5c1381ea2fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: elementh <hello@lucasmarino.me>
+pkgname=anytype-bin
+pkgver=0.18.51
+pkgrel=1
+pkgdesc="Operating environment for the new internet. Anytype is a next generation software that breaks down barriers between applications, gives back privacy and data ownership to users."
+arch=('x86_64')
+url="https://anytype.io/"
+license=('custom')
+depends=('fuse')
+options=(!strip)
+optdepends=()
+provides=('anytype')
+conflicts=('anytype')
+_appimage="Anytype-${pkgver}.AppImage"
+source=(
+ "Anytype-${pkgver}.AppImage::https://download.anytype.io/?action=download&id=40825766"
+ "anytype.desktop"
+ "anytype.png"
+ )
+noextract=("${_appimage}")
+sha256sums=('572b2bc3fa183d924ebf2d5ad25a3e79cadf0d808ac1c4455469a55e9dbad0f4'
+ '1bda1398291bed84ebee1d2c3e94b4c367925a8e2c0bd371aba8d6604e54281f'
+ '48ee23a45c29cf081ccf5188c045150b7410007cd21743ce8592974ab18120c0')
+
+package() {
+ install -Dm755 $_appimage "$pkgdir"/usr/bin/anytype
+ chmod +x "${pkgdir}/usr/bin/anytype"
+
+ install -Dm644 "anytype.desktop" "${pkgdir}/usr/share/applications/anytype.desktop"
+ install -Dm644 "anytype.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/anytype.png"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..45d998eaffab
--- /dev/null
+++ b/README.md
@@ -0,0 +1,38 @@
+# Anytype
+
+PKGBUILD for Anytype's binary AUR package.
+
+## What is Anytype?
+
+> Anytype is a next generation software that breaks
+> down barriers between applications, gives back
+> privacy and data ownership to users.
+
+More information can be found [here](https://anytype.io).
+## AUR
+
+The AUR package can be found [here](https://aur.archlinux.org/packages/anytype-bin/).
+
+## License
+
+MIT License
+
+Copyright (c) 2021 Lucas Maximiliano Marino
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/anytype.desktop b/anytype.desktop
new file mode 100644
index 000000000000..78b72eff6a29
--- /dev/null
+++ b/anytype.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Anytype
+Comment=Operating environment for the new internet
+Exec=anytype
+Terminal=false
+Type=Application
+Icon=anytype
+StartupWMClass=Anytype
+X-AppImage-Version=1.1.3
+Categories=Internet;
diff --git a/anytype.png b/anytype.png
new file mode 100644
index 000000000000..39a2cc3466b7
--- /dev/null
+++ b/anytype.png
Binary files differ