summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShohei Kusakata2015-08-12 00:57:29 +0900
committerShohei Kusakata2015-08-12 00:57:29 +0900
commit68c7230cc9abd99eebe2aa7eeec4032da30dbeea (patch)
tree1e91f996c553e6f4f2943c12f9eb9839ca917807
downloadaur-68c7230cc9abd99eebe2aa7eeec4032da30dbeea.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
-rw-r--r--aobook.install11
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f7d58d15751
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = aobook
+ pkgdesc = Aozora Bunko text viewer
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = http://azsky2.html.xdomain.jp/linux/aobook/
+ install = aobook.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = fontconfig
+ depends = hicolor-icon-theme
+ depends = libjpeg-turbo
+ depends = libx11
+ depends = libxext
+ depends = xdg-utils
+ source = http://dl.osdn.jp/aobook/62557/aobook-1.0.1.tar.bz2
+ md5sums = 48965417717ee70ad95b8b06b36e076b
+
+pkgname = aobook
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5923b41f077
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: kusakata <shohei atmark kusakata period com>
+
+pkgname=aobook
+pkgver=1.0.1
+_sfver=62557
+pkgrel=1
+pkgdesc='Aozora Bunko text viewer'
+arch=('i686' 'x86_64')
+url="http://azsky2.html.xdomain.jp/linux/aobook/"
+license=('BSD')
+depends=('fontconfig' 'hicolor-icon-theme' 'libjpeg-turbo' 'libx11' 'libxext' 'xdg-utils')
+install=aobook.install
+source=("http://dl.osdn.jp/aobook/${_sfver}/aobook-${pkgver}.tar.bz2")
+
+build() {
+ cd "${srcdir}/aobook-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/aobook-${pkgver}"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
+
+md5sums=('48965417717ee70ad95b8b06b36e076b')
diff --git a/aobook.install b/aobook.install
new file mode 100644
index 000000000000..734001649fe7
--- /dev/null
+++ b/aobook.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}