summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarjan Krijan2019-10-04 16:01:55 +0200
committerDarjan Krijan2019-10-04 16:01:55 +0200
commit4352113d6729ccab0cf7630679063a15609896e3 (patch)
tree0b07efff6c8124a10f45836f38be88426d09129e
downloadaur-4352113d6729ccab0cf7630679063a15609896e3.tar.gz
First commit
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD77
-rw-r--r--amd-blis-mt.pc9
-rw-r--r--amd-blis.pc9
-rw-r--r--amd-fftw3.pc10
-rw-r--r--amd-fftw3f.pc10
-rw-r--r--amd-libflame.pc9
-rw-r--r--amd-libm.pc9
-rw-r--r--amd-rng-omp.pc9
-rw-r--r--amd-rng.pc9
-rw-r--r--amd-securerng.pc9
-rw-r--r--aocl.install7
-rw-r--r--modulefile25
13 files changed, 228 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15610b9d6746
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = aocl
+ pkgdesc = AMD Optimizing CPU Libraries
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://developer.amd.com/amd-aocl/
+ install = aocl.install
+ arch = x86_64
+ license = custom
+ depends = env-modules
+ options = staticlibs
+ options = !strip
+ source = local://aocl-ubuntu-2.0.tar.gz
+ source = local://amd-blis.pc
+ source = local://amd-blis-mt.pc
+ source = local://amd-fftw3.pc
+ source = local://amd-fftw3f.pc
+ source = local://amd-libflame.pc
+ source = local://amd-libm.pc
+ source = local://amd-rng.pc
+ source = local://amd-rng-omp.pc
+ source = local://amd-securerng.pc
+ source = local://modulefile
+ sha256sums = 4fd14dc838ce13a6d1468ed0812905b102d85709b17ab8228513da37448d2993
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = aocl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6da427bbb731
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Maintainer: Darjan Krijan (daren) <darjan_krijan@gmx.de>
+# Manual download of 'aocl-ubuntu-${pkgver}.tar.gz' required from upstream
+
+pkgname=aocl
+pkgver=2.0
+pkgrel=1
+pkgdesc="AMD Optimizing CPU Libraries"
+arch=('x86_64')
+license=('custom')
+url="https://developer.amd.com/amd-aocl/"
+source=(
+ "local://aocl-ubuntu-${pkgver}.tar.gz"
+ "local://amd-blis.pc"
+ "local://amd-blis-mt.pc"
+ "local://amd-fftw3.pc"
+ "local://amd-fftw3f.pc"
+ "local://amd-libflame.pc"
+ "local://amd-libm.pc"
+ "local://amd-rng.pc"
+ "local://amd-rng-omp.pc"
+ "local://amd-securerng.pc"
+ "local://modulefile"
+)
+options=('staticlibs' '!strip')
+depends=('env-modules')
+install=aocl.install
+sha256sums=(
+ "4fd14dc838ce13a6d1468ed0812905b102d85709b17ab8228513da37448d2993"
+ "SKIP"
+ "SKIP"
+ "SKIP"
+ "SKIP"
+ "SKIP"
+ "SKIP"
+ "SKIP"
+ "SKIP"
+ "SKIP"
+ "SKIP"
+)
+
+package() {
+ mkdir -p ${pkgdir}/opt/aocl
+
+ cd ${srcdir}/aocl-ubuntu-${pkgver}
+
+ ./install.sh -t ${pkgdir}/opt/aocl
+ cp AOCL_User_Guide_${pkgver}.pdf ${pkgdir}/opt/aocl
+ mv ${pkgdir}/opt/aocl/amd/aocl/${pkgver}/* ${pkgdir}/opt/aocl
+
+ # clean amd-libm
+ mv ${pkgdir}/opt/aocl/amd-libm/lib/dynamic/* \
+ ${pkgdir}/opt/aocl/amd-libm/lib
+ mv ${pkgdir}/opt/aocl/amd-libm/lib/static/* \
+ ${pkgdir}/opt/aocl/amd-libm/lib
+ rm -r ${pkgdir}/opt/aocl/amd-libm/lib/dynamic
+ rm -r ${pkgdir}/opt/aocl/amd-libm/lib/static
+
+ # clean amd-rng
+ mv ${pkgdir}/opt/aocl/amd-rng/rng-omp/lib_omp/* \
+ ${pkgdir}/opt/aocl/amd-rng/rng-omp/lib
+ rm -r ${pkgdir}/opt/aocl/amd-rng/rng-omp/lib_omp/
+ rm -r ${pkgdir}/opt/aocl/amd-rng/rng/lib/libamdsecrng*
+ rm -r ${pkgdir}/opt/aocl/amd-rng/rng-omp/lib/libamdsecrng*
+
+ rm -rf ${pkgdir}/opt/aocl/amd ${pkgdir}/opt/aocl/libs
+
+ cd ${srcdir}
+
+ # pkg-config
+ mkdir -p ${pkgdir}/opt/aocl/pkgconfig
+ cp ${srcdir}/*.pc ${pkgdir}/opt/aocl/pkgconfig
+
+ # modulefile
+ cp modulefile ${pkgdir}/opt/aocl
+ mkdir -p ${pkgdir}${MODULESHOME}/modulefiles/
+ ln -s /opt/aocl/modulefile ${pkgdir}${MODULESHOME}/modulefiles/aocl
+}
diff --git a/amd-blis-mt.pc b/amd-blis-mt.pc
new file mode 100644
index 000000000000..2b7b01465909
--- /dev/null
+++ b/amd-blis-mt.pc
@@ -0,0 +1,9 @@
+libdir=/opt/aocl/amd-blis-mt/lib
+includedir=/opt/aocl/amd-blis-mt/include
+
+Name: AMD Multi-threaded BLIS
+Description: BLIS is a portable software framework for instantiating high-performance BLAS-like dense linear algebra libraries
+Version: 2.0
+URL: https://developer.amd.com/amd-aocl/blas-library/
+Libs: -L${libdir} -lblis-mt
+Cflags: -I${includedir}
diff --git a/amd-blis.pc b/amd-blis.pc
new file mode 100644
index 000000000000..19c9590e6a3b
--- /dev/null
+++ b/amd-blis.pc
@@ -0,0 +1,9 @@
+libdir=/opt/aocl/amd-blis/lib
+includedir=/opt/aocl/amd-blis/include
+
+Name: AMD BLIS
+Description: BLIS is a portable software framework for instantiating high-performance BLAS-like dense linear algebra libraries
+Version: 2.0
+URL: https://developer.amd.com/amd-aocl/blas-library/
+Libs: -L${libdir} -lblis
+Cflags: -I${includedir}
diff --git a/amd-fftw3.pc b/amd-fftw3.pc
new file mode 100644
index 000000000000..00e5a86bb3ba
--- /dev/null
+++ b/amd-fftw3.pc
@@ -0,0 +1,10 @@
+libdir=/opt/aocl/amd-fftw/lib
+includedir=/opt/aocl/amd-fftw/include
+
+Name: AMD FFTW
+Description: Fast Fourier transform library
+Version: 2.0
+URL: https://developer.amd.com/amd-aocl/fftw/
+Libs: -L${libdir} -lfftw3
+Libs.private: -lm
+Cflags: -I${includedir}
diff --git a/amd-fftw3f.pc b/amd-fftw3f.pc
new file mode 100644
index 000000000000..22eda36c79ad
--- /dev/null
+++ b/amd-fftw3f.pc
@@ -0,0 +1,10 @@
+libdir=/opt/aocl/amd-fftw/lib
+includedir=/opt/aocl/amd-fftw/include
+
+Name: AMD FFTW (single precision)
+Description: Fast Fourier transform library
+Version: 2.0
+URL: https://developer.amd.com/amd-aocl/fftw/
+Libs: -L${libdir} -lfftw3f
+Libs.private: -lm
+Cflags: -I${includedir}
diff --git a/amd-libflame.pc b/amd-libflame.pc
new file mode 100644
index 000000000000..8a03e8318dd7
--- /dev/null
+++ b/amd-libflame.pc
@@ -0,0 +1,9 @@
+libdir=/opt/aocl/amd-libflame/lib
+includedir=/opt/aocl/amd-libflame/include
+
+Name: AMD libFLAME
+Description: libFLAME is a portable library for dense matrix computations, providing much of the functionality present in LAPACK
+Version: 2.0
+URL: https://developer.amd.com/amd-aocl/blas-library/
+Libs: -L${libdir} -lflame
+Cflags: -I${includedir}
diff --git a/amd-libm.pc b/amd-libm.pc
new file mode 100644
index 000000000000..1b6df48b7c33
--- /dev/null
+++ b/amd-libm.pc
@@ -0,0 +1,9 @@
+libdir=/opt/aocl/amd-libm/lib
+includedir=/opt/aocl/amd-libm/include
+
+Name: AMD libm
+Description: AMD LibM is a software library containing a collection of basic math functions optimized for x86-64 processor based machines
+Version: 3.4.0
+URL: https://developer.amd.com/amd-aocl/amd-math-library-libm/
+Libs: -L${libdir} -lamdlibm
+Cflags: -I${includedir}
diff --git a/amd-rng-omp.pc b/amd-rng-omp.pc
new file mode 100644
index 000000000000..37cc87efcb9d
--- /dev/null
+++ b/amd-rng-omp.pc
@@ -0,0 +1,9 @@
+libdir=/opt/aocl/amd-rng/rng-omp/lib
+includedir=/opt/aocl/amd-rng/rng-omp/include
+
+Name: AMD RNG
+Description: AMD Random Number Generator Library is a pseudorandom number generator library. A pseudo-random number generator (PRNG) produces a stream of variates that are independent and statistically indistinguishable from a random sequence
+Version: 2.0
+URL: https://developer.amd.com/amd-aocl/rng-library/
+Libs: -L${libdir} -lrng_omp_amd
+Cflags: -I${includedir}
diff --git a/amd-rng.pc b/amd-rng.pc
new file mode 100644
index 000000000000..c6c9cc643d61
--- /dev/null
+++ b/amd-rng.pc
@@ -0,0 +1,9 @@
+libdir=/opt/aocl/amd-rng/rng/lib
+includedir=/opt/aocl/amd-rng/rng/include
+
+Name: AMD RNG
+Description: AMD Random Number Generator Library is a pseudorandom number generator library. A pseudo-random number generator (PRNG) produces a stream of variates that are independent and statistically indistinguishable from a random sequence
+Version: 2.0
+URL: https://developer.amd.com/amd-aocl/rng-library/
+Libs: -L${libdir} -lrng_amd
+Cflags: -I${includedir}
diff --git a/amd-securerng.pc b/amd-securerng.pc
new file mode 100644
index 000000000000..a1f3ef194052
--- /dev/null
+++ b/amd-securerng.pc
@@ -0,0 +1,9 @@
+libdir=/opt/aocl/amd-securerng/lib
+includedir=/opt/aocl/amd-securerng/include
+
+Name: AMD Secure RNG Library
+Description: The AMD Secure Random Number Generator (RNG) is a library that provides APIs to access the cryptographically secure random numbers generated by AMD’s hardware-based random number generator implementation
+Version: 2.0
+URL: https://developer.amd.com/amd-aocl/rng-library/
+Libs: -L${libdir} -lamdsecrng
+Cflags: -I${includedir}
diff --git a/aocl.install b/aocl.install
new file mode 100644
index 000000000000..d6470eb32fc1
--- /dev/null
+++ b/aocl.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo "Use 'module load aocl' to set up the environment for AMD Optimizing CPU Libraries."
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/modulefile b/modulefile
new file mode 100644
index 000000000000..8ac75c209a04
--- /dev/null
+++ b/modulefile
@@ -0,0 +1,25 @@
+#%Module1.0
+#
+# Created by Darjan Krijan <darjan_krijan@gmx.de>
+#
+
+set MODULE "aocl"
+set BASE_DIR "/opt"
+set VERSION "2.0"
+set AOCL_ROOT "$BASE_DIR/$MODULE"
+set AOCL_TEXT "AMD Optimizing CPU Libraries"
+
+append-path PKG_CONFIG_PATH $AOCL_ROOT/pkgconfig
+
+module-whatis "$AOCL_TEXT version $VERSION"
+
+proc ModulesHelp {} {
+ global AOCL_TEXT
+ puts stderr "This module sets up the environment for $AOCL_TEXT"
+ puts stderr "by adapting the following environment variables:"
+ puts stderr "PATH"
+ puts stderr "LIBRARY_PATH"
+ puts stderr "LD_LIBRARY_PATH"
+ puts stderr "C_INCLUDE_PATH"
+ puts stderr "CPLUS_INCLUDE_PATH"
+}