summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn-Michael Mulesa2021-09-27 10:05:35 +1000
committerJohn-Michael Mulesa2021-09-27 10:05:35 +1000
commit77e0ce4da3019d43082dbedb7ac1f836b1d53693 (patch)
treecb67ea55fcac1c00fce12caac733deb7ca576094
parenta7ba929b6e56b967e43320905092d6b340dedac4 (diff)
downloadaur-77e0ce4da3019d43082dbedb7ac1f836b1d53693.tar.gz
Minor fixes.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD30
-rw-r--r--aoe3.sh13
3 files changed, 27 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eff2c5e0c27d..d707c45aa606 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aoe3-wine-steam
pkgdesc = Age of Empires 3 using WINE with data via Steam
pkgver = 1.03
- pkgrel = 1
+ pkgrel = 2
url = https://store.steampowered.com/app/105450/Age_of_Empires_III_2007/
install = aoe3.install
arch = i686
@@ -13,8 +13,10 @@ pkgbase = aoe3-wine-steam
source = aoe3.sh
source = aoe3.desktop
source = aoe3.png
- sha256sums = c1bcb8d0a59a584bd6275f94ed9f2fb3d90fc75556dc401dcfea04910110063f
+ sha256sums = 51f4b1145dcbbc8f3c15cd704540d72473c9f7924b5ade8429faecaefa209067
sha256sums = 7a53cc2f88e8ee8d4233428438870803f4e662a4b8ee61a3c05aa1fe8541745c
sha256sums = ec3d23d8b0a15a10ed15141fd236efb523f056745df3aabed29e0a6eb71689b9
+ depends_i686 = mpg123
+ depends_x86_64 = lib32-mpg123
pkgname = aoe3-wine-steam
diff --git a/PKGBUILD b/PKGBUILD
index 21ce5954e02e..e090b09c3e73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,48 @@
# Maintainer: John-Michael Mulesa <jmulesa [at] gmail.com>
pkgname=aoe3-wine-steam
+_pkgname=aoe3
pkgver=1.03
-pkgrel=1
+pkgrel=2
+_steamid=105450
arch=('i686' 'x86_64')
makedepends=('steamcmd')
depends=('wine' 'winetricks')
-source=("aoe3.sh" "aoe3.desktop" "aoe3.png")
+depends_i686=('mpg123')
+depends_x86_64=('lib32-mpg123')
+source=("${_pkgname}.sh" "${_pkgname}.desktop" "${_pkgname}.png")
pkgdesc="Age of Empires 3 using WINE with data via Steam"
install=aoe3.install
license=('custom')
url='https://store.steampowered.com/app/105450/Age_of_Empires_III_2007/'
-sha256sums=('c1bcb8d0a59a584bd6275f94ed9f2fb3d90fc75556dc401dcfea04910110063f'
+sha256sums=('51f4b1145dcbbc8f3c15cd704540d72473c9f7924b5ade8429faecaefa209067'
'7a53cc2f88e8ee8d4233428438870803f4e662a4b8ee61a3c05aa1fe8541745c'
'ec3d23d8b0a15a10ed15141fd236efb523f056745df3aabed29e0a6eb71689b9')
prepare() {
- mkdir -p $srcdir/aoe3
+ mkdir -p $srcdir/${_pkgname}
# Use steamcmd to get data.
printf "Enter your Steam username:"
read steam_username
- steamcmd +@sSteamCmdForcePlatformType windows +@ShutdownOnFailedCommand 1 +force_install_dir $srcdir/aoe3 +login $steam_username "+app_update 105450 validate" +quit
+ steamcmd +@sSteamCmdForcePlatformType windows +@ShutdownOnFailedCommand 1 +force_install_dir $srcdir/${_pkgname} +login $steam_username "+app_update ${_steamid} validate" +quit
}
package() {
- mkdir -p $pkgdir/opt/aoe3
+ mkdir -p $pkgdir/opt/${_pkgname}
# Move required files to pkgdir
- cp -r $srcdir/aoe3/bin/* $pkgdir/opt/aoe3/
+ cp -r $srcdir/${_pkgname}/bin/* $pkgdir/opt/${_pkgname}/
# Install desktop file.
- install -D -m 644 $srcdir/aoe3.desktop \
- $pkgdir/usr/share/applications/aoe3.desktop
+ install -D -m 644 $srcdir/${_pkgname}.desktop \
+ $pkgdir/usr/share/applications/${_pkgname}.desktop
# Install icon file.
- install -D -m 644 $srcdir/aoe3.png \
- $pkgdir/usr/share/pixmaps/aoe3.png
+ install -D -m 644 $srcdir/${_pkgname}.png \
+ $pkgdir/usr/share/pixmaps/${_pkgname}.png
# Install bash startup script.
- install -D -m 755 $srcdir/aoe3.sh \
- $pkgdir/usr/bin/aoe3
+ install -D -m 755 $srcdir/${_pkgname}.sh \
+ $pkgdir/usr/bin/${_pkgname}
}
diff --git a/aoe3.sh b/aoe3.sh
index 604cb7df3fe4..75c522f65599 100644
--- a/aoe3.sh
+++ b/aoe3.sh
@@ -3,21 +3,20 @@ export WINEPREFIX="$HOME"/.aoe3/wine
if [ ! -d "$HOME"/.aoe3 ] ; then
mkdir -p "$HOME"/.aoe3/wine
wineboot -u
- # vcrun6 fails to install; still fixing audio
- winetricks corefonts d9vk quartz mfc42 l3codecx msxml4 riched20
+ winetricks courier mfc42 d9vk
fi
cd /opt/aoe3
-while getopts ":oxy" opt; do
+while getopts ":oxyh" opt; do
case ${opt} in
- o ) /usr/bin/wine age3.exe
+ o ) /usr/bin/wine age3.exe +noIntroCinematics
;;
- x ) /usr/bin/wine age3x.exe
+ x ) /usr/bin/wine age3x.exe +noIntroCinematics
;;
- y ) /usr/bin/wine age3y.exe
+ y ) /usr/bin/wine age3y.exe +noIntroCinematics
;;
h ) echo "Usage: aoe3 [-o: original age3.exe|-x warchiefs age3x.exe|-y asiandynasties age3y.exe (default)]"
;;
esac
exit
done
-/usr/bin/wine age3y.exe
+/usr/bin/wine age3y.exe +noIntroCinematics