summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMort Yao2017-03-05 21:07:44 +0100
committerMort Yao2017-03-05 21:07:44 +0100
commit31abb3f154ad8310cccd7bce7f37a927cb6dfe78 (patch)
tree484fc136bc70611bdb29e164081defffd6be36da
parentfe3d702b8545471da3d8858b191dacb94b3b0f3b (diff)
downloadaur-31abb3f154ad8310cccd7bce7f37a927cb6dfe78.tar.gz
[aoi] 3.0.3-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--aoi.sh2
3 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5bd00975984..cbafa10d62c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Feb 5 21:07:03 UTC 2016
+# Sun Mar 5 20:06:45 UTC 2017
pkgbase = aoi
pkgdesc = A 3D modeling and rendering studio (Art of Illusion)
- pkgver = 3.0.2
+ pkgver = 3.0.3
pkgrel = 1
url = http://www.artofillusion.org/
arch = any
@@ -11,10 +11,10 @@ pkgbase = aoi
depends = java-environment
optdepends = jmf: QuickTime animation support
optdepends = jogl: OpenGL rendering support
- source = http://sourceforge.net/projects/aoi/files/ArtOfIllusion/3.0.2/aoi302.zip
+ source = http://sourceforge.net/projects/aoi/files/ArtOfIllusion/3.0.3/ArtOfIllusion303-Linux.zip
source = aoi.sh
- md5sums = a1847a0c330dcb6ff207acfcf19cd74a
- md5sums = b2c2de959cf1112a729da857bc15111c
+ md5sums = 7e2392a28bc3fcfb0618c0395b1fc3fd
+ md5sums = 061e5a5fe148e29dbac63fc027c26de0
pkgname = aoi
diff --git a/PKGBUILD b/PKGBUILD
index 056af6570a9e..90490b0d5f85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: dsr <dsr@archlinux.us>
pkgname=aoi
-pkgver=3.0.2
+pkgver=3.0.3
pkgrel=1
pkgdesc="A 3D modeling and rendering studio (Art of Illusion)"
arch=('any')
@@ -14,10 +14,10 @@ depends=('java-environment')
optdepends=('jmf: QuickTime animation support'
'jogl: OpenGL rendering support')
makedepends=('gendesk')
-source=(http://sourceforge.net/projects/aoi/files/ArtOfIllusion/${pkgver}/aoi${pkgver//./}.zip
+source=(http://sourceforge.net/projects/aoi/files/ArtOfIllusion/${pkgver}/ArtOfIllusion${pkgver//./}-Linux.zip
aoi.sh)
-md5sums=('a1847a0c330dcb6ff207acfcf19cd74a'
- 'b2c2de959cf1112a729da857bc15111c')
+md5sums=('7e2392a28bc3fcfb0618c0395b1fc3fd'
+ '061e5a5fe148e29dbac63fc027c26de0')
build() {
cd "$srcdir"
@@ -29,8 +29,7 @@ build() {
package() {
install -dm755 "$pkgdir/usr/share/java"
- cp -r ArtOfIllusion${pkgver//./} "$pkgdir/usr/share/java/aoi"
+ cp -r . "$pkgdir/usr/share/java/aoi"
install -Dm755 aoi.sh "$pkgdir/usr/bin/aoi"
install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
- install -Dm644 "ArtOfIllusion${pkgver//./}/Icons/64x64.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
}
diff --git a/aoi.sh b/aoi.sh
index 0b1a86b7561c..88faa1aaae9c 100644
--- a/aoi.sh
+++ b/aoi.sh
@@ -1,3 +1,3 @@
#!/bin/sh
-java -Xmx512m -jar /usr/share/java/aoi/ArtOfIllusion.jar
+java -Xmx512m -jar /usr/share/java/aoi/AOI-Linux-303.jar