summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatti Niemenmaa2018-02-11 12:23:09 +0200
committerMatti Niemenmaa2018-02-11 12:25:27 +0200
commitaaa17310da414e357ddb416c7859cb7f734cadf2 (patch)
tree1da57c8f4a0b86a6e8fbc395aa9d72e59e1ffd06
downloadaur-aaa17310da414e357ddb416c7859cb7f734cadf2.tar.gz
Initial commit: custom Makefile and tweak for GCC
Packages libaopsf.so and aopsf/psx_external.h, and any headers that it requires (currently just ao.h).
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--LICENSE.BSD24
-rw-r--r--PKGBUILD41
-rw-r--r--decl.patch13
-rw-r--r--makefile.patch8
6 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec2d874b3c01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = aopsf-git
+ pkgdesc = Audio Overload's PSF core, now in a proper library
+ pkgver = r26.08672d5
+ pkgrel = 1
+ url = https://gitlab.kode54.net/kode54/aopsf
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ source = aopsf-git::git+https://gitlab.kode54.net/kode54/aopsf.git
+ source = makefile.patch
+ source = decl.patch
+ source = LICENSE.BSD
+ sha256sums = SKIP
+ sha256sums = 4855f2d7969a595e1dae79a3cb600ae0cd73e5a7f2b1c838f3014c6211abf1c0
+ sha256sums = b807bf78052965584faff4d3767c2ed9974c74c61fa469727b309bf263b6777f
+ sha256sums = 3fb3258f12e481be1326b6931269b55866bb3ed5c0e769ecad83f9e71c3cdfca
+
+pkgname = aopsf-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c45d9ee5a16b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/aopsf-git*
+/pkg
+/src
diff --git a/LICENSE.BSD b/LICENSE.BSD
new file mode 100644
index 000000000000..2cd92c1ba5ff
--- /dev/null
+++ b/LICENSE.BSD
@@ -0,0 +1,24 @@
+Audio Overload SDK - Sony Playstation audio emulator
+
+Copyright (c) 2007-2008 R. Belmont and Richard Bannister.
+Copyright (c) 2015 Christopher Snowhill
+
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
+
+* Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
+* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
+* Neither the names of R. Belmont and Richard Bannister nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
+CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..349f85067362
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+pkgname=aopsf-git
+pkgver=r26.08672d5
+pkgrel=1
+pkgdesc="Audio Overload's PSF core, now in a proper library"
+arch=(x86_64)
+url='https://gitlab.kode54.net/kode54/aopsf'
+license=(BSD)
+makedepends=(git)
+source=(${pkgname}::git+https://gitlab.kode54.net/kode54/aopsf.git makefile.patch decl.patch LICENSE.BSD)
+sha256sums=('SKIP'
+ '4855f2d7969a595e1dae79a3cb600ae0cd73e5a7f2b1c838f3014c6211abf1c0'
+ 'b807bf78052965584faff4d3767c2ed9974c74c61fa469727b309bf263b6777f'
+ '3fb3258f12e481be1326b6931269b55866bb3ed5c0e769ecad83f9e71c3cdfca')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ test -e Makefile || patch -p0 < "$srcdir"/makefile.patch
+ patch -p0 < "$srcdir"/decl.patch
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -D -m644 -t "$pkgdir/usr/lib" libaopsf.so
+ install -D -m644 -t "$pkgdir/usr/include/aopsf" psx_external.h ao.h
+ install -D -m644 -t "$pkgdir/usr/share/licenses/$pkgname" "$srcdir"/LICENSE.BSD
+}
+
+# vim:set sw=2 et:
diff --git a/decl.patch b/decl.patch
new file mode 100644
index 000000000000..c7788ce8e3da
--- /dev/null
+++ b/decl.patch
@@ -0,0 +1,13 @@
+diff --git psx_hw.c psx_hw.c
+index 3e2a914..ec5ebf2 100644
+--- psx_hw.c
++++ psx_hw.c
+@@ -55,6 +55,8 @@
+ #include "psx_external.h"
+ #include "psx_internal.h"
+
++uint32 ioptimer_lw(struct IOPTIMER_STATE *state, offs_t offset, uint32 mem_mask);
++
+ #if DEBUG_THREADING
+ static char *_ThreadStateNames[TS_MAXSTATE] = { "RUNNING", "DORMANT", "WAITEVFLAG", "WAITSEMA", "WAITDELAY", "SLEEPING" };
+ #endif
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..90c84afc4c9f
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,8 @@
+diff --git Makefile Makefile
+new file mode 100644
+--- /dev/null
++++ Makefile
+@@ -0,0 +1,3 @@
++CFLAGS += -fPIC -DEMU_COMPILE -DEMU_LITTLE_ENDIAN
++libaopsf.so: eng_psf.o eng_psf2.o psx.o psx_hw.o r3000dis.o spu/spu.o spu/spucore.o
++ $(CC) -shared -o $@ $^