summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfancy2020-05-08 04:43:09 +0800
committerfancy2020-05-08 04:43:09 +0800
commitc0f1afc5c87c26eac1d3710fe381ce98be8831d1 (patch)
tree9d09f5c44ed3636664d04a5cf9e0741d78dac7d6
downloadaur-c0f1afc5c87c26eac1d3710fe381ce98be8831d1.tar.gz
updated
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a7e80a4e654
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ap
+ pkgdesc = simple wireless ap support both ipv4 and ipv6 with nat
+ pkgver = v1.0.r1.gbd42539
+ pkgrel = 1
+ url = https://github.com/springzfx/ap
+ arch = x86_64
+ license = GPL
+ depends = hostapd
+ depends = dnsmasq
+ optdepends = systemd: for service
+ backup = etc/ap/ap.conf
+ source = ap-git::git+https://github.com/springzfx/ap#branch=master
+ md5sums = SKIP
+
+pkgname = ap-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f7c1754d718
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Fancy Zhang <springzfx@gmail.com>
+pkgbase=ap
+pkgname=ap-git
+pkgver=v1.0.r1.gbd42539
+pkgrel=1
+pkgdesc="simple wireless ap support both ipv4 and ipv6 with nat"
+arch=('x86_64')
+url="https://github.com/springzfx/ap"
+license=('GPL')
+depends=('hostapd' 'dnsmasq')
+optdepends=('systemd: for service')
+
+source=('ap-git::git+https://github.com/springzfx/ap#branch=master')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s" "$(git rev-list --count HEAD)"
+ )
+}
+
+backup=('etc/ap/ap.conf')
+
+package_ap(){
+ cd "$pkgname"
+ install -d ${pkgdir}/usr/lib/systemd/system/ ${pkgdir}/etc/ap/ ${pkgdir}/usr/share/ap/ ${pkgdir}/usr/bin/
+ install -m 544 ap.service ${pkgdir}/usr/lib/systemd/system/
+ install -m 544 ap.sh ${pkgdir}/usr/bin/ap
+ install -m 644 ap.conf ${pkgdir}/etc/ap/
+ install -m 544 iptables-add.sh iptables-del.sh dnsmasq-template.sh hostapd-template.sh ${pkgdir}/usr/share/ap/
+}