summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2015-09-18 23:19:55 +0800
committerYen Chi Hsuan2015-09-18 23:19:55 +0800
commit04e2e799a087920286c02ade182c05d4f2803329 (patch)
tree7105967a045eacb989e5ca09032c43dce463417a
parent44befa7b2cf5013401c53a7aef698d79c565d901 (diff)
downloadaur-04e2e799a087920286c02ade182c05d4f2803329.tar.gz
Remove *.bat files from bin/
They're totally useless on Linux.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36f3c08a5871..02e5637fe9ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = apache-flex-sdk
pkgdesc = The open-source framework for building expressive web and mobile applications
pkgver = 4.14.1
- pkgrel = 1
+ pkgrel = 2
url = http://flex.apache.org/
install = apache-flex-sdk.install
arch = any
@@ -11,7 +11,7 @@ pkgbase = apache-flex-sdk
optdepends = adobe-air-sdk: for compiling flex projects into AIR apps
noextract = playerglobal11_1.swc
options = !strip
- source = http://ftp.twaren.net/Unix/Web/apache/flex/4.14.1/binaries/apache-flex-sdk-4.14.1-bin.tar.gz
+ source = http://www.apache.org/dist/flex/4.14.1/binaries/apache-flex-sdk-4.14.1-bin.tar.gz
source = http://www.apache.org/dist/flex/4.14.1/binaries/apache-flex-sdk-4.14.1-bin.tar.gz.asc
source = http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_1.swc
source = apache-flex-sdk.sh
diff --git a/PKGBUILD b/PKGBUILD
index 7b1d9e72681b..a5fc60c9d145 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=apache-flex-sdk
pkgver=4.14.1
-pkgrel=1
+pkgrel=2
pkgdesc="The open-source framework for building expressive web and mobile applications"
arch=('any')
license=('Apache')
@@ -14,8 +14,7 @@ optdepends=(
'adobe-air-sdk: for compiling flex projects into AIR apps'
)
source=(
- "http://ftp.twaren.net/Unix/Web/apache/flex/$pkgver/binaries/apache-flex-sdk-$pkgver-bin.tar.gz"
- "http://www.apache.org/dist/flex/$pkgver/binaries/apache-flex-sdk-$pkgver-bin.tar.gz.asc"
+ "http://www.apache.org/dist/flex/$pkgver/binaries/apache-flex-sdk-$pkgver-bin.tar.gz"{,.asc}
"http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_1.swc"
"apache-flex-sdk.sh"
)
@@ -33,15 +32,15 @@ noextract=('playerglobal11_1.swc')
_binary_name="${pkgname}-${pkgver}-bin.tar.gz"
build() {
- cd ${srcdir}/${pkgname}-${pkgver}-bin/
+ cd "${srcdir}/${pkgname}-${pkgver}-bin/"
mkdir -p player/11.1/
cp ../playerglobal11_1.swc player/11.1/playerglobal.swc
}
package() {
- cd ${srcdir}
- install -dDm755 ${pkgdir}/opt
- cp -dr --no-preserve=ownership ${pkgname}-${pkgver}-bin ${pkgdir}/opt/${pkgname}
- install -dDm755 ${pkgdir}/etc/profile.d/
- install -Dm755 apache-flex-sdk.sh ${pkgdir}/etc/profile.d/
+ cd "${srcdir}"
+ install -dDm755 "${pkgdir}/opt"
+ cp -dr --no-preserve=ownership ${pkgname}-${pkgver}-bin "${pkgdir}/opt/${pkgname}"
+ rm "${pkgdir}/opt/${pkgname}/bin/"*.bat
+ install -Dm755 apache-flex-sdk.sh "${pkgdir}/etc/profile.d/apache-flex-sdk.sh"
}