summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2014-03-07 12:00:15 +0800
committerYen Chi Hsuan2014-03-07 12:00:15 +0800
commit3fcfa524f27f77e3f0fc6cf3c5c91955367e8057 (patch)
treefe6c1d15ee5fc67922f79ea960ac2593ad923257
downloadaur-3fcfa524f27f77e3f0fc6cf3c5c91955367e8057.tar.gz
First commit. Put 3 packages here.
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD40
-rw-r--r--apache-flex-sdk.install3
-rw-r--r--apache-flex-sdk.sh2
-rw-r--r--closer.py9
5 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36f3c08a5871
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = apache-flex-sdk
+ pkgdesc = The open-source framework for building expressive web and mobile applications
+ pkgver = 4.14.1
+ pkgrel = 1
+ url = http://flex.apache.org/
+ install = apache-flex-sdk.install
+ arch = any
+ license = Apache
+ depends = bash
+ depends = java-runtime
+ optdepends = adobe-air-sdk: for compiling flex projects into AIR apps
+ noextract = playerglobal11_1.swc
+ options = !strip
+ source = http://ftp.twaren.net/Unix/Web/apache/flex/4.14.1/binaries/apache-flex-sdk-4.14.1-bin.tar.gz
+ source = http://www.apache.org/dist/flex/4.14.1/binaries/apache-flex-sdk-4.14.1-bin.tar.gz.asc
+ source = http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_1.swc
+ source = apache-flex-sdk.sh
+ sha256sums = d238eac494ebfb225c638c4427f383638ab33b019021e976c000f17962c47a2a
+ sha256sums = SKIP
+ sha256sums = 2bbd5ffff3bb20c117db7206080079479b04c4b55d68dd21ab31b6566c99fb6b
+ sha256sums = 520ae01482825ef28da42c03b3cbadd3d62155ed074d737f3672980f0a97a3fd
+
+pkgname = apache-flex-sdk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d75852320795
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+pkgname=apache-flex-sdk
+pkgver=4.11.0
+pkgrel=1
+pkgdesc="The open-source framework for building expressive web and mobile applications"
+arch=('any')
+license=('Apache')
+url='http://flex.apache.org/'
+depends=('java-runtime')
+makedepends=('python-pyquery')
+source=(
+ "`python ./closer.py`"
+ "http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_1.swc"
+ "apache-flex-sdk.sh"
+ "closer.py"
+)
+sha256sums=(
+ '180e440f47c73fc74e808ff044e5b37e8dc3440e1559eef45587853450a1a636'
+ '2bbd5ffff3bb20c117db7206080079479b04c4b55d68dd21ab31b6566c99fb6b'
+ '520ae01482825ef28da42c03b3cbadd3d62155ed074d737f3672980f0a97a3fd'
+ '77cb6573e511441d91c60b37558fe50b8dd60d7881e3e82f1c67f913586abed1'
+)
+install=apache-flex-sdk.install
+options=('!strip')
+noextract=('playerglobal11_1.swc')
+
+_binary_name="${pkgname}-${pkgver}-bin.tar.gz"
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}-bin/
+ mkdir -p player/11.1/
+ cp ../playerglobal11_1.swc player/11.1/playerglobal.swc
+}
+
+package() {
+ cd ${srcdir}
+ install -dDm755 ${pkgdir}/opt
+ cp -dr --no-preserve=ownership ${pkgname}-${pkgver}-bin ${pkgdir}/opt/${pkgname}
+ install -dDm755 ${pkgdir}/etc/profile.d/
+ install -Dm755 apache-flex-sdk.sh ${pkgdir}/etc/profile.d/
+}
diff --git a/apache-flex-sdk.install b/apache-flex-sdk.install
new file mode 100644
index 000000000000..5350ef84a136
--- /dev/null
+++ b/apache-flex-sdk.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo Please re-login or source /etc/profile to use the new \$PATH
+}
diff --git a/apache-flex-sdk.sh b/apache-flex-sdk.sh
new file mode 100644
index 000000000000..20fb9343c70e
--- /dev/null
+++ b/apache-flex-sdk.sh
@@ -0,0 +1,2 @@
+export PLAYERGLOBAL_HOME=/opt/apache-flex-sdk/player
+export PATH="${PATH}":/opt/apache-flex-sdk/bin
diff --git a/closer.py b/closer.py
new file mode 100644
index 000000000000..6c928d7afa64
--- /dev/null
+++ b/closer.py
@@ -0,0 +1,9 @@
+#!/usr/bin/env python3
+# determine the mirror dynamically
+from pyquery import PyQuery as pq
+import sys
+
+print('If download failed, retry it', file=sys.stderr)
+apache_flex_sdk_url = 'http://www.apache.org/dyn/closer.cgi/flex/4.11.0/binaries/apache-flex-sdk-4.11.0-bin.tar.gz'
+dom = pq(url=apache_flex_sdk_url)
+print(dom('.section-content a:first').attr('href'))