summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12019-05-24 21:04:04 +0800
committerChocobo12019-05-24 22:05:39 +0800
commit6a69894ac22f9f841cfeaf9a81ee878c13f8d40d (patch)
treeaa31bdc79b4e9ab23266f62ee3237c01b5d61dfc
downloadaur-6a69894ac22f9f841cfeaf9a81ee878c13f8d40d.tar.gz
newpkg: apache-git 2.5.0.alpha.r1107.gbdff1daffc-1
-rw-r--r--.SRCINFO58
-rw-r--r--PKGBUILD122
2 files changed, 180 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f61aaeb31371
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,58 @@
+pkgbase = apache-git
+ pkgdesc = Provides useful functions commonly found on BSD systems
+ pkgver = 2.5.0.alpha.r1107.gbdff1daffc
+ pkgrel = 1
+ url = https://httpd.apache.org/
+ arch = i686
+ arch = x86_64
+ license = apache
+ makedepends = git
+ makedepends = brotli
+ makedepends = curl
+ makedepends = jansson
+ makedepends = libxml2
+ makedepends = lua
+ depends = glibc
+ depends = apr-util
+ depends = libnghttp2
+ depends = openssl
+ depends = pcre
+ depends = zlib
+ optdepends = brotli: for mod_brotli module
+ optdepends = curl: for mod_md module
+ optdepends = jansson: for mod_md module
+ optdepends = libxml2: for mod_proxy_html, mod_xml2enc modules
+ optdepends = lua: for mod_lua module
+ optdepends = lynx: apachectl status
+ optdepends = uwsgi: for mod_proxy_uwsgi module
+ provides = apache
+ conflicts = apache
+ backup = etc/httpd/conf/httpd.conf
+ backup = etc/httpd/conf/extra/httpd-autoindex.conf
+ backup = etc/httpd/conf/extra/httpd-dav.conf
+ backup = etc/httpd/conf/extra/httpd-default.conf
+ backup = etc/httpd/conf/extra/httpd-info.conf
+ backup = etc/httpd/conf/extra/httpd-languages.conf
+ backup = etc/httpd/conf/extra/httpd-manual.conf
+ backup = etc/httpd/conf/extra/httpd-mpm.conf
+ backup = etc/httpd/conf/extra/httpd-multilang-errordoc.conf
+ backup = etc/httpd/conf/extra/httpd-ssl.conf
+ backup = etc/httpd/conf/extra/httpd-userdir.conf
+ backup = etc/httpd/conf/extra/httpd-vhosts.conf
+ backup = etc/httpd/conf/extra/proxy-html.conf
+ backup = etc/httpd/conf/mime.types
+ backup = etc/httpd/conf/magic
+ backup = etc/logrotate.d/httpd
+ source = git+https://github.com/apache/httpd.git
+ source = apache.tmpfiles.conf::https://git.archlinux.org/svntogit/packages.git/plain/trunk/apache.tmpfiles.conf?h=packages/apache
+ source = arch.layout::https://git.archlinux.org/svntogit/packages.git/plain/trunk/arch.layout?h=packages/apache
+ source = httpd.logrotate::https://git.archlinux.org/svntogit/packages.git/plain/trunk/httpd.logrotate?h=packages/apache
+ source = httpd.service::https://git.archlinux.org/svntogit/packages.git/plain/trunk/httpd.service?h=packages/apache
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = apache-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..decec402f445
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,122 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=apache-git
+pkgver=2.5.0.alpha.r1107.gbdff1daffc
+pkgrel=1
+pkgdesc="Provides useful functions commonly found on BSD systems"
+arch=('i686' 'x86_64')
+url="https://httpd.apache.org/"
+license=('apache')
+depends=('glibc' 'apr-util' 'libnghttp2' 'openssl' 'pcre' 'zlib')
+makedepends=('git' 'brotli' 'curl' 'jansson' 'libxml2' 'lua')
+optdepends=(
+ 'brotli: for mod_brotli module'
+ 'curl: for mod_md module'
+ 'jansson: for mod_md module'
+ 'libxml2: for mod_proxy_html, mod_xml2enc modules'
+ 'lua: for mod_lua module'
+ 'lynx: apachectl status'
+ 'uwsgi: for mod_proxy_uwsgi module')
+provides=('apache')
+conflicts=('apache')
+backup=(
+ 'etc/httpd/conf/httpd.conf'
+ 'etc/httpd/conf/extra'/httpd-{autoindex,dav,default,info,languages,manual,mpm,multilang-errordoc,ssl,userdir,vhosts}.conf
+ 'etc/httpd/conf/extra/proxy-html.conf'
+ 'etc/httpd/conf'/{mime.types,magic}
+ 'etc/logrotate.d/httpd')
+#options=('staticlibs')
+source=("git+https://github.com/apache/httpd.git"
+ "apache.tmpfiles.conf::https://git.archlinux.org/svntogit/packages.git/plain/trunk/apache.tmpfiles.conf?h=packages/apache"
+ "arch.layout::https://git.archlinux.org/svntogit/packages.git/plain/trunk/arch.layout?h=packages/apache"
+ "httpd.logrotate::https://git.archlinux.org/svntogit/packages.git/plain/trunk/httpd.logrotate?h=packages/apache"
+ "httpd.service::https://git.archlinux.org/svntogit/packages.git/plain/trunk/httpd.service?h=packages/apache")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+
+prepare() {
+ cd "httpd"
+
+ # set default user
+ sed -e 's#User daemon#User http#' \
+ -e 's#Group daemon#Group http#' \
+ -i "docs/conf/httpd.conf.in"
+
+ echo "$srcdir/arch.layout" >> "config.layout"
+}
+
+pkgver() {
+ cd "httpd"
+
+ _tag=$(git tag -l --sort -v:refname | grep -m1 "^[0-9]")
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/-/./g'
+}
+
+build() {
+ cd "httpd"
+
+ ./buildconf --with-apr=apr-1-config
+ ./configure \
+ --prefix="/usr" \
+ --sbindir="/usr/bin" \
+ --enable-layout=Arch \
+ --enable-mpms-shared=all \
+ --enable-modules=all \
+ --enable-mods-shared=all \
+ --enable-so \
+ --enable-suexec \
+ --with-suexec-caller=http \
+ --with-suexec-docroot="/srv/http" \
+ --with-suexec-logfile="/var/log/httpd/suexec.log" \
+ --with-suexec-bin="/usr/bin/suexec" \
+ --with-suexec-uidmin=99 --with-suexec-gidmin=99 \
+ --enable-ldap --enable-authnz-ldap --enable-authnz-fcgi \
+ --enable-cache --enable-disk-cache --enable-mem-cache --enable-file-cache \
+ --enable-ssl --with-ssl \
+ --enable-deflate --enable-cgi --enable-cgid \
+ --enable-proxy --enable-proxy-connect \
+ --enable-proxy-http --enable-proxy-ftp \
+ --enable-dbd --enable-imagemap --enable-ident --enable-cern-meta \
+ --enable-lua --enable-xml2enc --enable-http2 \
+ --enable-proxy-http2 --enable-md --enable-brotli \
+ --with-apr="/usr/bin/apr-1-config" \
+ --with-apr-util="/usr/bin/apu-1-config" \
+ --with-pcre="/usr"
+ make
+}
+
+package() {
+ cd "httpd"
+
+ make DESTDIR="$pkgdir" install
+ install -D -m644 "LICENSE" -t "$pkgdir/usr/share/licenses/apache"
+
+ install -D -m644 "$srcdir/httpd.logrotate" "$pkgdir/etc/logrotate.d/httpd"
+ install -D -m644 "$srcdir/httpd.service" -t "$pkgdir/usr/lib/systemd/system"
+ install -D -m644 "$srcdir/apache.tmpfiles.conf" "$pkgdir/usr/lib/tmpfiles.d/apache.conf"
+
+ # set sane defaults
+ sed -e 's#/usr/lib/httpd/modules/#modules/#' \
+ -e 's|#\(LoadModule negotiation_module \)|\1|' \
+ -e 's|#\(LoadModule include_module \)|\1|' \
+ -e 's|#\(LoadModule userdir_module \)|\1|' \
+ -e 's|#\(LoadModule slotmem_shm_module \)|\1|' \
+ -e 's|#\(Include conf/extra/httpd-multilang-errordoc.conf\)|\1|' \
+ -e 's|#\(Include conf/extra/httpd-autoindex.conf\)|\1|' \
+ -e 's|#\(Include conf/extra/httpd-languages.conf\)|\1|' \
+ -e 's|#\(Include conf/extra/httpd-userdir.conf\)|\1|' \
+ -e 's|#\(Include conf/extra/httpd-default.conf\)|\1|' \
+ -e 's|#\(Include conf/extra/httpd-mpm.conf\)|\1|' \
+ -i "$pkgdir/etc/httpd/conf/httpd.conf"
+
+ # cleanup
+ rm -r "$pkgdir/etc/httpd/conf/original"
+ rm -r "$pkgdir/run"
+ rm -r "$pkgdir/srv"
+}