summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2021-02-22 10:59:30 +0100
committerGilrain2021-02-22 10:59:30 +0100
commit7c3dba2a6d3f7a3f85447337846b0456917b8f99 (patch)
tree07ff4f503b37e4014c69c163096e6feeeb23dbf3
downloadaur-7c3dba2a6d3f7a3f85447337846b0456917b8f99.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--.install10
-rw-r--r--PKGBUILD38
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1e498fcbe13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = apache-h5bp-server-configs
+ pkgdesc = Apache HTTP server boilerplate configs
+ pkgver = 4.1.0
+ pkgrel = 1
+ url = https://github.com/h5bp/server-configs-apache
+ install = .install
+ arch = any
+ license = MIT
+ depends = apache
+ provides = apache-h5bp-server-configs
+ source = apache-h5bp-server-configs.4.1.0.tar.gz::https://github.com/h5bp/server-configs-apache/archive/4.1.0.tar.gz
+ b2sums = b0034cf1b74ff5539ecf386a87f2f973f1e122084cdccc797b7e05d8441f4c7df5e33f003367f91b778a3e14b8074c1e2b6662ca28842f4df631b05de12ae8e1
+
+pkgname = apache-h5bp-server-configs
+
diff --git a/.install b/.install
new file mode 100644
index 000000000000..6a7d79652fe9
--- /dev/null
+++ b/.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo 'Start using the h5bp configuration by copying the example HTTPD'
+ echo 'configuration from `/etc/httpd/conf/vhosts/templates/example.com.conf`'
+ echo 'to the `/etc/httpd/conf/vhosts` directory with the desired domain and'
+ echo 'top level name to your liking.'
+}
+
+post_update() {
+ post_install
+}
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..387e65a1d698
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+# Contributor: Joseph R. Quinn <quinn period josephr at protonmail dot com>
+# Contributor: Ewout van Mansom <ewout at vanmansom dot name>
+
+pkgname=apache-h5bp-server-configs
+_pkgname=server-configs-apache
+pkgver=4.1.0
+pkgrel=1
+pkgdesc="Apache HTTP server boilerplate configs"
+arch=('any')
+url="https://github.com/h5bp/server-configs-apache"
+license=('MIT')
+depends=('apache')
+provides=("$pkgname")
+install='.install'
+source=("${pkgname}.${pkgver}.tar.gz::https://github.com/h5bp/$_pkgname/archive/$pkgver.tar.gz")
+b2sums=('b0034cf1b74ff5539ecf386a87f2f973f1e122084cdccc797b7e05d8441f4c7df5e33f003367f91b778a3e14b8074c1e2b6662ca28842f4df631b05de12ae8e1')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+
+ sed -i '/ServerRoot/s_"/usr/local/apache2"_"/etc/httpd"_' 'httpd.conf'
+ sed -i '/User/s/www-data/httpd/' 'httpd.conf'
+ sed -i '/Group/s/www-data/httpd/' 'httpd.conf'
+ sed -i '/ErrorLog/s_logs/error.log_/var/log/httpd/error\_log_' 'httpd.conf'
+
+ sed -i '/SSLSessionCache/s_"shmcb:/usr/local/apache2/logs/ssl\_gcache\_data(10485760)"_"shmcb:/run/httpd/ssl\_scache(10485760)"_' 'h5bp/ssl/ssl_engine.conf'
+ sed -i '/SSLStaplingCache/s_shmcb:/var/run/ocsp(128000)_shmcb:/run/httpd/ssl\_stapling(128000)_' 'h5bp/ssl/ocsp_stapling.conf'
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ install -d "$pkgdir/etc/httpd/conf"
+ install -Dm644 httpd.conf "$pkgdir/etc/httpd/conf/httpd.conf.example"
+ mv h5bp "$pkgdir/etc/httpd/conf"
+ mv vhosts "$pkgdir/etc/httpd/conf"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}