summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2018-05-30 14:31:51 +0200
committerLucas Werkmeister2018-05-30 14:31:51 +0200
commit40029c9bf96c26ba410ad24c2dfa79ee4f86f99f (patch)
tree1d16d045af15c620fb9198f607cf32839f4d5c3e
downloadaur-40029c9bf96c26ba410ad24c2dfa79ee4f86f99f.tar.gz
Initial commit
Yeah, I know, dumping everything in /opt sucks, but I don’t have the time right now to do it better :(
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f17725aef0e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Wed May 30 12:31:47 UTC 2018
+pkgbase = apache-jena
+ pkgdesc = Java framework for building Semantic Web and Linked Data applications
+ pkgver = 3.7.0
+ pkgrel = 1
+ url = https://jena.apache.org/
+ arch = any
+ license = Apache
+ depends = java-runtime
+ source = http://www-us.apache.org/dist/jena/binaries/apache-jena-3.7.0.tar.gz
+ sha512sums = eb28d5fb50589377a24016472e69808cf08d1091c2527e8c81fc0d1e4b4ca842e2eacaf9fa1c2c7b31d45c32266648dd072600c032aca84ab1d0a675bca8b94d
+
+pkgname = apache-jena
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f532e343aba0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Lucas Werkmeister <mail@lucaswerkmeister.de>
+# TODO improve installation per https://wiki.archlinux.org/index.php/Java_package_guidelines – several of the dependencies have their own packages
+pkgname=apache-jena
+pkgver=3.7.0
+pkgrel=1
+pkgdesc='Java framework for building Semantic Web and Linked Data applications'
+arch=('any')
+url='https://jena.apache.org/'
+license=('Apache')
+depends=('java-runtime')
+source=("http://www-us.apache.org/dist/${pkgname/apache-/}/binaries/${pkgname}-${pkgver}.tar.gz")
+sha512sums=('eb28d5fb50589377a24016472e69808cf08d1091c2527e8c81fc0d1e4b4ca842e2eacaf9fa1c2c7b31d45c32266648dd072600c032aca84ab1d0a675bca8b94d')
+
+package() {
+ cd "$pkgname-$pkgver"
+ mkdir -p "$pkgdir/opt/${pkgname}/" "$pkgdir/usr/bin/"
+
+ # install most files in /opt (yes, I know, I know :/ see TODO at the top)
+ cp -r -t "$pkgdir/opt/${pkgname}/" bin/ lib/ LICENSE NOTICE README jena-log4j.properties
+
+ # symlink binaries into /usr/bin
+ cd bin
+ for bin in *; do
+ # some binaries conflict with other packages, so install them all with a "jena." prefix
+ ln -s "../../opt/${pkgname}/bin/${bin}" "$pkgdir/usr/bin/jena.${bin}"
+ case "$bin" in
+ schemagen)
+ # conflicts with a different binary by java-environment-common
+ ;;
+ tdbbackup|tdbdump)
+ # conflicts with different binaries by tdb
+ ;;
+ *)
+ # no conflicts, also install without "jena." prefix
+ ln -s "jena.${bin}" "$pkgdir/usr/bin/${bin}"
+ ;;
+ esac
+ done
+}