summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2018-05-30 15:06:49 +0200
committerLucas Werkmeister2018-05-30 15:06:49 +0200
commit61b1a5f0a9659c1b12aeab206db1d36d5923f274 (patch)
tree3f52f88d4be8e8c7f1681d6ed50682129345a109
downloadaur-61b1a5f0a9659c1b12aeab206db1d36d5923f274.tar.gz
Initial commit
Does not include the systemd service shipped by upstream yet, since I’m not sure how useful that will be without local customizations.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
-rwxr-xr-xfuseki-server3
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..efb80d206e34
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed May 30 13:06:32 UTC 2018
+pkgbase = apache-jena-fuseki
+ pkgdesc = SPARQL server built on the Jena Java framework for building Semantic Web and Linked Data applications
+ pkgver = 3.7.0
+ pkgrel = 1
+ url = https://jena.apache.org/
+ arch = any
+ license = Apache
+ depends = java-runtime
+ source = http://www-us.apache.org/dist/jena/binaries/apache-jena-fuseki-3.7.0.tar.gz
+ source = fuseki-server
+ sha512sums = 5f81e7a59400ee2dcee0b0ede9ecaaea0013ac80f2ddc134262d6aa7e333359a7c617c6b70cc6ba97df53221acbb0f7194d824f61f56dfbc031f78728022bd4b
+ sha512sums = SKIP
+
+pkgname = apache-jena-fuseki
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ddd5daa6f09c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Lucas Werkmeister <mail@lucaswerkmeister.de>
+# TODO try to rip apart the fat jar and improve installation per https://wiki.archlinux.org/index.php/Java_package_guidelines
+pkgname=apache-jena-fuseki
+pkgver=3.7.0
+pkgrel=1
+pkgdesc='SPARQL server built on the Jena Java framework for building Semantic Web and Linked Data applications'
+arch=('any')
+url='https://jena.apache.org/'
+license=('Apache')
+depends=('java-runtime') # does not depend on apache-jena – included in the fat jar
+source=(
+ "http://www-us.apache.org/dist/jena/binaries/${pkgname}-${pkgver}.tar.gz"
+ 'fuseki-server'
+)
+sha512sums=(
+ '5f81e7a59400ee2dcee0b0ede9ecaaea0013ac80f2ddc134262d6aa7e333359a7c617c6b70cc6ba97df53221acbb0f7194d824f61f56dfbc031f78728022bd4b'
+ 'SKIP'
+)
+
+package() {
+ cd "$pkgname-$pkgver"
+ mkdir -p "$pkgdir/opt/${pkgname}/" "$pkgdir/usr/bin/"
+
+ # install most files in /opt (yes, I know, I know :/ see TODO at the top)
+ cp -r -t "$pkgdir/opt/${pkgname}/" fuseki-server.jar webapp/
+
+ # install our own binary into /usr/bin (ignore the one shipped by upstream)
+ install -D -t "$pkgdir/usr/bin/" ../fuseki-server
+}
diff --git a/fuseki-server b/fuseki-server
new file mode 100755
index 000000000000..d363e66f5714
--- /dev/null
+++ b/fuseki-server
@@ -0,0 +1,3 @@
+#!/bin/sh
+export FUSEKI_HOME=/opt/apache-jena-fuseki
+exec /usr/bin/java -jar "$FUSEKI_HOME/fuseki-server.jar" "$@"