summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2017-01-23 17:33:45 +0800
committerJingbei Li2017-01-23 17:33:45 +0800
commit7f71a491e279fb705b262537366722848e592436 (patch)
tree9c94fafb60fec852afc052c89e81b11f7f6468e8
parentd84319b675c3822b3d81470a32de768fd858539b (diff)
downloadaur-7f71a491e279fb705b262537366722848e592436.tar.gz
install *.jar only
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD4
3 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08e3718aeb88..98b56b9fab1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jan 23 08:03:52 UTC 2017
+# Mon Jan 23 09:33:19 UTC 2017
pkgbase = apache-lucene
pkgdesc = Apache Lucene is a high-performance, full-featured text search engine library written entirely in Java.
pkgver = 6.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://lucene.apache.org/
arch = any
license = APACHE
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8c10a647b5ba
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg*
+*.tgz
+*/
+*.sw*
diff --git a/PKGBUILD b/PKGBUILD
index 5fa6420a56ba..17e623ecfe2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=lucene
pkgname=apache-$_pkgname
pkgver=6.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Apache Lucene is a high-performance, full-featured text search engine library written entirely in Java."
arch=('any')
url="https://lucene.apache.org/"
@@ -16,6 +16,6 @@ md5sums=('6330abfc46231a73bd6a4caeb660c412')
package() {
cd "${srcdir}/$_pkgname-$pkgver"
mkdir -p $pkgdir/usr/share/java/$pkgname
- cp -r * $pkgdir/usr/share/java/$pkgname
+ find . -type f -name '*.jar' -exec mv {} $pkgdir/usr/share/java/$pkgname \;
install -Dm644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
}