summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2017-01-23 16:02:32 +0800
committerJingbei Li2017-01-23 16:02:32 +0800
commit9cfa1dc467ac2a924e2cb5ca6ad34fef994acbd0 (patch)
tree6c4ade67e724dc653cfff413fabc269846a986dd
downloadaur-9cfa1dc467ac2a924e2cb5ca6ad34fef994acbd0.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebb9e23cd0f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Mon Jan 23 08:02:27 UTC 2017
+pkgbase = apache-lucene
+ pkgdesc = Apache Lucene is a high-performance, full-featured text search engine library written entirely in Java.
+ pkgver = 6.3.0
+ pkgrel = 1
+ url = https://lucene.apache.org/
+ arch = any
+ license = APACHE
+ depends = java-runtime
+ source = http://mirrors.tuna.tsinghua.edu.cn/apache/lucene/java/6.3.0/lucene-6.3.0.tgz
+ md5sums = 6330abfc46231a73bd6a4caeb660c412
+
+pkgname = apache-lucene
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f93fd1797946
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Jingbei Li <i@jingbei.li>
+
+_pkgname=lucene
+pkgname=apache-$_pkgname
+pkgver=6.3.0
+pkgrel=1
+pkgdesc="Apache Lucene is a high-performance, full-featured text search engine library written entirely in Java."
+arch=('any')
+url="https://lucene.apache.org/"
+license=('APACHE')
+depends=('java-runtime')
+_mirror="http://mirrors.tuna.tsinghua.edu.cn/apache"
+source=("$_mirror/$_pkgname/java/$pkgver/$_pkgname-${pkgver}.tgz")
+md5sums=('6330abfc46231a73bd6a4caeb660c412')
+
+package() {
+ cd "${srcdir}/$_pkgname-$pkgver"
+ mkdir -p $pkgdir/usr/share/$pkgname
+ cp -r * $pkgdir/usr/share/$pkgname
+ install -Dm644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+}