summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikola Ivačič2017-04-04 14:05:18 +0200
committerNikola Ivačič2017-04-04 14:05:18 +0200
commitd9eb42fdcc45381727df04f5ab99f19f8af5739a (patch)
tree502d56226ed938b03b1554cb5935b584f207e02a
downloadaur-d9eb42fdcc45381727df04f5ab99f19f8af5739a.tar.gz
Initial commit for mod_auth_mellon package.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f99aa39d147d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = apache-mod_auth_mellon
+ pkgdesc = Authentication module for Apache that authenticates the user against a SAML 2.0 IdP, and grants access to directories depending on attributes received from the IdP.
+ pkgver = 0.13.1
+ pkgrel = 1
+ url = https://github.com/UNINETT/mod_auth_mellon
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = apache
+ depends = apache
+ source = https://github.com/UNINETT/mod_auth_mellon/releases/download/v0.13.1/mod_auth_mellon-0.13.1.tar.gz
+ sha512sums = ad0479be8aa94404a832d11f7ead1f704d86cab2f11aa6f90b895be9b4028026f15ec8ee85260ca76f4a001c115ff14b4b7c9e8da74676a1f0295f6c2f0a1341
+
+pkgname = apache-mod_auth_mellon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0210a06b7d52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Nikola Ivačič <nikola.ivacic@dropchop.com>
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=apache-mod_auth_mellon
+pkgver=0.13.1
+pkgrel=1
+pkgdesc="Authentication module for Apache that authenticates the user against a SAML 2.0 IdP, and grants access to directories depending on attributes received from the IdP."
+arch=('i686' 'x86_64')
+url="https://github.com/UNINETT/mod_auth_mellon"
+license=('LGPL')
+depends=('apache' 'lasso')
+source=("https://github.com/UNINETT/mod_auth_mellon/releases/download/v${pkgver}/mod_auth_mellon-${pkgver}.tar.gz")
+sha512sums=('ad0479be8aa94404a832d11f7ead1f704d86cab2f11aa6f90b895be9b4028026f15ec8ee85260ca76f4a001c115ff14b4b7c9e8da74676a1f0295f6c2f0a1341')
+
+build() {
+ cd "$srcdir"/mod_auth_mellon-$pkgver
+ apxs -L/usr/lib -I/usr/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -I/usr/include/xmlsec1 -c mod_auth_mellon.c
+}
+
+package() {
+ cd "$srcdir"/mod_auth_mellon-$pkgver
+ install -Dm0755 .libs/mod_auth_mellon.so $pkgdir/usr/lib/httpd/modules/mod_auth_mellon.so
+}