summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Smith2016-06-28 09:18:36 +1000
committerPhillip Smith2016-06-28 09:18:36 +1000
commitae4e5bd68b223c5a32341e231536b2f8842f2b7c (patch)
treeeb462c2e8376ee1f84cf8dd77e27ac468fb55e14
parent0efdc83896641e190a4afb24b0710eeac723e0a1 (diff)
downloadaur-apache-mod_form.tar.gz
upgpkg: apache-mod_form 1.0-1
upstream release apache-mod_form; our patch has been applied upstream; remove from PKGBUILD
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
-rw-r--r--preserve-args.patch24
3 files changed, 7 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b17f63bb685..63b36f868afd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Mon Jun 27 23:18:36 UTC 2016
pkgbase = apache-mod_form
pkgdesc = A utility to decode data submitted from Web forms. It deals with both GET and POST methods where the data are encoded using the default content type application/x-www-form-urlencoded.
pkgver = 1.0
@@ -10,10 +12,8 @@ pkgbase = apache-mod_form
depends = apache
source = http://apache.webthing.com/svn/apache/forms/mod_form.c
source = http://apache.webthing.com/svn/apache/forms/mod_form.h
- source = preserve-args.patch
- md5sums = 8339effe63ec1ea8ade1e8b90aabb23c
- md5sums = e524cf838ae990bf6e118d985b1b91ca
- md5sums = 24f531501e999ff46bdbb920edf7a4a4
+ sha256sums = fea0d16ad45be310658bc623d9d9ad9d82bd3f4aedc80ecb969a534b56124437
+ sha256sums = 70bd77cbce33c2031890a4c7cc4e069555aa2d15bb2a9c432f947005bdb82d49
pkgname = apache-mod_form
diff --git a/PKGBUILD b/PKGBUILD
index 6f6d36259eed..4530b4a03986 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,25 +21,9 @@ license=('GPL')
depends=('apache')
makedepends=('patch')
source=("http://apache.webthing.com/svn/apache/forms/mod_form.c"
- "http://apache.webthing.com/svn/apache/forms/mod_form.h"
- 'preserve-args.patch')
-md5sums=('8339effe63ec1ea8ade1e8b90aabb23c'
- 'e524cf838ae990bf6e118d985b1b91ca'
- '24f531501e999ff46bdbb920edf7a4a4')
-
-prepare() {
- # we need to copy the source files into a clean subdir
- # because makepkg now symlinks source files to the parent
- # directory. we could use --follow-symlinks but the
- # patch man page says that is discouraged.
- rm -Rf "$srcdir"/$pkgname-$pkgversion || true # cleanup if makepkg has been previously run
- mkdir "$srcdir"/$pkgname-$pkgversion
- cp --dereference "$srcdir"/mod_form.? preserve-args.patch $pkgname-$pkgversion/
-
- cd "$srcdir"/$pkgname-$pkgversion
-
- patch < preserve-args.patch
-}
+ "http://apache.webthing.com/svn/apache/forms/mod_form.h")
+sha256sums=('fea0d16ad45be310658bc623d9d9ad9d82bd3f4aedc80ecb969a534b56124437'
+ '70bd77cbce33c2031890a4c7cc4e069555aa2d15bb2a9c432f947005bdb82d49')
build() {
cd "$srcdir"/$pkgname-$pkgversion
diff --git a/preserve-args.patch b/preserve-args.patch
deleted file mode 100644
index 20b87d3ad9b8..000000000000
--- a/preserve-args.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-preserve r->args (apr_strtok is destructive in this regard). Makes
-mod_autoindex work again in conjunction with directories where FormGET is
-enabled.
-
---- mod_form.c.old 2007-03-13 15:05:13.872945000 +0100
-+++ mod_form.c 2007-03-13 15:06:26.378367000 +0100
-@@ -61,6 +61,7 @@
- char* pair ;
- char* last = NULL ;
- char* eq ;
-+ char* a ;
- if ( ! ctx ) {
- ctx = apr_pcalloc(r->pool, sizeof(form_ctx)) ;
- ctx->delim = delim[0];
-@@ -69,7 +70,8 @@
- if ( ! ctx->vars ) {
- ctx->vars = apr_table_make(r->pool, 10) ;
- }
-- for ( pair = apr_strtok(args, delim, &last) ; pair ;
-+ a = apr_pstrdup(r->pool, args);
-+ for ( pair = apr_strtok(a, delim, &last) ; pair ;
- pair = apr_strtok(NULL, delim, &last) ) {
- for (eq = pair ; *eq ; ++eq)
- if ( *eq == '+' )