summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikola Ivačič2017-04-04 09:27:29 +0200
committerNikola Ivačič2017-04-04 09:27:29 +0200
commit819561e7773f1fb62e9ea3120e715022518098d9 (patch)
tree8f743710685c6e9411401c7f03ecaebc75be7451
downloadaur-819561e7773f1fb62e9ea3120e715022518098d9.tar.gz
Initial Apache mod_h264_streaming package commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aaf53aa866b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = apache-mod_h264_streaming
+ pkgdesc = H264 Streaming Module for Apache.
+ pkgver = 2.2.7
+ pkgrel = 1
+ url = http://h264.code-shop.com/trac/wiki/Mod-H264-Streaming-Apache-Version2
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = apache
+ depends = apache
+ source = http://h264.code-shop.com/download/apache_mod_h264_streaming-2.2.7.tar.gz
+ md5sums = 123cacef68e9ff56fe908200bd0feea5
+
+pkgname = apache-mod_h264_streaming
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b43e658e3bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Nikola Ivačič <nikola.ivacic@dropchop.com>
+
+pkgname=apache-mod_h264_streaming
+pkgver=2.2.7
+pkgrel=1
+pkgdesc="H264 Streaming Module for Apache."
+arch=('i686' 'x86_64')
+url="http://h264.code-shop.com/trac/wiki/Mod-H264-Streaming-Apache-Version2"
+license=('LGPL')
+depends=('apache')
+makedepends=('apache')
+source=("http://h264.code-shop.com/download/apache_mod_h264_streaming-${pkgver}.tar.gz")
+md5sums=('123cacef68e9ff56fe908200bd0feea5')
+
+build() {
+ cd "$srcdir"/mod_h264_streaming-$pkgver/src
+ apxs -L/usr/lib -I/usr/include -DBUILDING_H264_STREAMING -c mod_h264_streaming.c moov.c mp4_io.c mp4_reader.c mp4_writer.c mp4_process.c output_bucket.c output_mp4.c
+}
+
+package() {
+ cd "$srcdir"/mod_h264_streaming-$pkgver/src
+ install -Dm0755 .libs/mod_h264_streaming.so $pkgdir/usr/lib/httpd/modules/mod_h264_streaming.so
+}