summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAakash Hemadri2024-05-07 23:09:28 +0530
committerAakash Hemadri2024-05-07 23:09:28 +0530
commit5f3b93d4271cc9aebad24ec87be49629f9687dd3 (patch)
treeb894245fa3c96514bd898fc6a3a2a39345e9726a
parent17a068f191dd614e705bce026ed1797cd626d359 (diff)
downloadaur-5f3b93d4271cc9aebad24ec87be49629f9687dd3.tar.gz
v3.5.1
Signed-off-by: Aakash Hemadri <aakashhemadri123@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile24
-rw-r--r--PKGBUILD6
3 files changed, 30 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d988714bb94f..96209d590ae8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = apache-spark
pkgdesc = A unified analytics engine for large-scale data processing
- pkgver = 3.5.0
+ pkgver = 3.5.1
pkgrel = 1
url = http://spark.apache.org
install = apache-spark.install
@@ -8,11 +8,11 @@ pkgbase = apache-spark
license = APACHE
depends = inetutils
depends = java-runtime-headless<=17
- source = https://dlcdn.apache.org/spark/spark-3.5.0/spark-3.5.0-bin-hadoop3.tgz
+ source = https://dlcdn.apache.org/spark/spark-3.5.1/spark-3.5.1-bin-hadoop3.tgz
source = apache-spark.sh
source = apache-spark-master.service
source = apache-spark-worker@.service
- sha256sums = ac064ec620129b4b9630e180e25ac2b71a8ccd4c6912bf5b5631943b742f0379
+ sha256sums = 5df15f8027067c060fe47ebd351a1431a61dbecc9c28b8dd29e2c6e1935c23eb
sha256sums = 0cc82baad4d878d4e2bc5864a00b99d38f2906781ea47ee6282546788e797049
sha256sums = de54c025ca8ce34a7b4fd95ec7b8d5dec44582787a0bd8da09232f26e2182c9a
sha256sums = 47e6c154daecf7631ac9a33fe53a76888070c823c4381fcbde8d98377e586505
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..74382d040030
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,24 @@
+# Helper make file
+BINARY:=apache-spark
+all: clean build install
+
+.PHONY: clean
+clean:
+ @echo "Cleaning build files..."
+ @rm -rf *.pkg.tar.xz *.zst *.zip pkg src *.log
+ @echo "Done."
+
+.PHONY: build
+build:
+ @updpkgsums ./PKGBUILD
+ @multilib-build -c -- -- -Acsf .
+ @makepkg --printsrcinfo > .SRCINFO
+
+.PHONY: install
+install:
+ @updpkgsums ./PKGBUILD
+ @makepkg -Ccip ./PKGBUILD --noconfirm
+
+.PHONY: uninstall
+uninstall:
+ @sudo pacman -R $(BINARY) --noconfirm
diff --git a/PKGBUILD b/PKGBUILD
index a29258daf735..8298da696cbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Emanuel Fontelles ("emanuelfontelles") <emanuelfontelles@hotmail.com>
pkgname=apache-spark
-pkgver=3.5.0
+pkgver=3.5.1
pkgrel=1
pkgdesc="A unified analytics engine for large-scale data processing"
arch=('any')
@@ -17,7 +17,7 @@ source=("https://dlcdn.apache.org/spark/spark-$pkgver/spark-$pkgver-bin-hadoop3.
'apache-spark.sh'
'apache-spark-master.service'
'apache-spark-worker@.service')
-sha256sums=('ac064ec620129b4b9630e180e25ac2b71a8ccd4c6912bf5b5631943b742f0379'
+sha256sums=('5df15f8027067c060fe47ebd351a1431a61dbecc9c28b8dd29e2c6e1935c23eb'
'0cc82baad4d878d4e2bc5864a00b99d38f2906781ea47ee6282546788e797049'
'de54c025ca8ce34a7b4fd95ec7b8d5dec44582787a0bd8da09232f26e2182c9a'
'47e6c154daecf7631ac9a33fe53a76888070c823c4381fcbde8d98377e586505')
@@ -28,7 +28,7 @@ prepare() {
cd spark-${pkgver}-bin-hadoop3
# Remove Python and R files
- rm -rf python R
+ # rm -rf python R
# Remove windows batch files
rm bin/*.cmd