summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Schlisio2015-07-07 23:01:44 +0200
committerGeorg Schlisio2015-07-07 23:01:44 +0200
commite7e57f65a1f68d08fa0283d7792a579049528391 (patch)
treeacb85b9a1edc950046b35e5eea8ba97617e70e79
downloadaur-e7e57f65a1f68d08fa0283d7792a579049528391.tar.gz
2.4.12; moved from aur3
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
-rw-r--r--apache-tools-Makefile.patch43
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..570c95aa65e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = apache-tools
+ pkgdesc = Useful Apache tools - htdigest, htpasswd, ab, htdbm
+ pkgver = 2.4.12
+ pkgrel = 1
+ url = http://httpd.apache.org/
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = apr-util
+ depends = pcre
+ conflicts = apache
+ source = http://www.apache.org/dist/httpd/httpd-2.4.12.tar.bz2
+ source = apache-tools-Makefile.patch
+ sha256sums = ad6d39edfe4621d8cc9a2791f6f8d6876943a9da41ac8533d77407a2e630eae4
+ sha256sums = 2dc48d34773b0c873d10e3542f77a4f7b50d5fb9bd8c52e3bb28b76ff9587f3f
+ sha512sums = f69db14b421f0e1e4861fe4d8b652688d50ca9eb41c622242d11ae55687eb6c2142a8505a8c3fb6f2bd53167be535bc0a77ca1af97e0720930fc7f20f4c1f8e8
+ sha512sums = 6e068e7820e852c788a521ad28c367af4c1c22fded51ede7ae3f840a8a04737cfbe4503c2f3f899c89461d984007e84f80376b5a8a27c7eec8ec0fd78155c22b
+
+pkgname = apache-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d3586df4b42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Limao Luo <luolimao+AUR@gmail.com>
+# Contributor: Marco A Rojas <marquicus@gmail.com>
+# Contributor: Pavel Larev <pavel@larev.ws>
+
+pkgname=apache-tools
+pkgver=2.4.12
+pkgrel=1
+pkgdesc="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+arch=(i686 x86_64)
+url=http://httpd.apache.org/
+license=(Apache)
+depends=(apr-util pcre)
+conflicts=(apache)
+source=(http://www.apache.org/dist/httpd/httpd-$pkgver.tar.bz2
+ $pkgname-Makefile.patch)
+sha256sums=('ad6d39edfe4621d8cc9a2791f6f8d6876943a9da41ac8533d77407a2e630eae4'
+ '2dc48d34773b0c873d10e3542f77a4f7b50d5fb9bd8c52e3bb28b76ff9587f3f')
+sha512sums=('f69db14b421f0e1e4861fe4d8b652688d50ca9eb41c622242d11ae55687eb6c2142a8505a8c3fb6f2bd53167be535bc0a77ca1af97e0720930fc7f20f4c1f8e8'
+ '6e068e7820e852c788a521ad28c367af4c1c22fded51ede7ae3f840a8a04737cfbe4503c2f3f899c89461d984007e84f80376b5a8a27c7eec8ec0fd78155c22b')
+
+prepare() {
+ cd httpd-$pkgver/
+ patch -p1 -i ../$pkgname-Makefile.patch
+}
+
+build() {
+ cd httpd-$pkgver/
+ ./configure --prefix=/usr --sbindir=/usr/bin --with-pcre=/usr
+ make -C support
+}
+
+package() {
+ make -C httpd-$pkgver/support DESTDIR="$pkgdir" install
+}
diff --git a/apache-tools-Makefile.patch b/apache-tools-Makefile.patch
new file mode 100644
index 000000000000..c39ef55357d9
--- /dev/null
+++ b/apache-tools-Makefile.patch
@@ -0,0 +1,43 @@
+--- a/support/Makefile.in 2012-12-11 05:37:25.000000000 -0500
++++ b/support/Makefile.in 2013-03-26 23:16:05.982719344 -0400
+@@ -1,9 +1,9 @@
+ DISTCLEAN_TARGETS = apxs apachectl dbmmanage log_server_status \
+- logresolve.pl phf_abuse_log.cgi split-logfile envvars-std
++ logresolve.pl phf_abuse_log.cgi split-logfile
+
+ CLEAN_TARGETS = suexec
+
+-bin_PROGRAMS = htpasswd htdigest htdbm ab logresolve httxt2dbm
++bin_PROGRAMS = htpasswd htdigest htdbm ab logresolve httxt2dbm dbmmanage
+ sbin_PROGRAMS = htcacheclean rotatelogs $(NONPORTABLE_SUPPORT)
+ TARGETS = $(bin_PROGRAMS) $(sbin_PROGRAMS)
+
+@@ -15,26 +15,18 @@
+ install:
+ @test -d $(DESTDIR)$(bindir) || $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
+ @test -d $(DESTDIR)$(sbindir) || $(MKINSTALLDIRS) $(DESTDIR)$(sbindir)
+- @test -d $(DESTDIR)$(libexecdir) || $(MKINSTALLDIRS) $(DESTDIR)$(libexecdir)
+- @cp -p $(top_builddir)/server/httpd.exp $(DESTDIR)$(libexecdir)
+- @for i in apxs dbmmanage; do \
++ @for i in $(bin_PROGRAMS); do \
+ if test -f "$(builddir)/$$i"; then \
+ cp -p $$i $(DESTDIR)$(bindir); \
+ chmod 755 $(DESTDIR)$(bindir)/$$i; \
+ fi ; \
+ done
+- @for i in apachectl; do \
++ @for i in $(sbin_PROGRAMS); do \
+ if test -f "$(builddir)/$$i"; then \
+ cp -p $$i $(DESTDIR)$(sbindir); \
+ chmod 755 $(DESTDIR)$(sbindir)/$$i; \
+ fi ; \
+ done
+- @if test -f "$(builddir)/envvars-std"; then \
+- cp -p envvars-std $(DESTDIR)$(sbindir); \
+- if test ! -f $(DESTDIR)$(sbindir)/envvars; then \
+- cp -p envvars-std $(DESTDIR)$(sbindir)/envvars ; \
+- fi ; \
+- fi
+
+ htpasswd.lo: passwd_common.h
+ passwd_common.lo: passwd_common.h