summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRanadeep Biswas2023-07-09 00:43:21 +0200
committerRanadeep Biswas2023-07-09 00:43:21 +0200
commit49bcea2f8520e57caf15040bb19435576264e37f (patch)
tree1d55fe82f1d8eac925cec3404ff39ab93cad198a
parent553256de5f99f6001a718b5131f9bbc5b4e8f00d (diff)
downloadaur-49bcea2f8520e57caf15040bb19435576264e37f.tar.gz
add service file
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--apalache.service13
3 files changed, 23 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d3c3fdd6c2d..c7e62d6325c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = apalache-bin
pkgdesc = A symbolic model checker for TLA+
pkgver = 0.40.7
- pkgrel = 1
+ pkgrel = 2
url = https://apalache.informal.systems/
arch = any
license = Apache
@@ -14,7 +14,9 @@ pkgbase = apalache-bin
conflicts = apalache
source = https://github.com/informalsystems/apalache/releases/download/v0.40.7/apalache-0.40.7.tgz
source = sys-install.patch
+ source = apalache.service
sha256sums = d31e51c49f91277c8fd87ff27a659149aeb8308b23b2c66c2074c9d3937fa301
sha256sums = c88201e1adeb5b50cfadfd55d071dedef8b3199cb1fcd5b5f008e5240be2f08d
+ sha256sums = 635ac8ddb7150d4d3437471cbdf5f72bf5e9d11a1039adec84e04c78ee1a39c9
pkgname = apalache-bin
diff --git a/PKGBUILD b/PKGBUILD
index 3ebe96042b6a..ce3339273e72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=apalache
pkgname=$_pkgname-bin
pkgver=0.40.7
-pkgrel=1
+pkgrel=2
pkgdesc="A symbolic model checker for TLA+"
arch=('any')
url="https://${_pkgname}.informal.systems/"
@@ -16,9 +16,11 @@ depends=('java-runtime>=11'
'util-linux')
makedepends=('patch')
source=("https://github.com/informalsystems/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tgz"
- 'sys-install.patch')
+ 'sys-install.patch'
+ 'apalache.service')
sha256sums=('d31e51c49f91277c8fd87ff27a659149aeb8308b23b2c66c2074c9d3937fa301'
- 'c88201e1adeb5b50cfadfd55d071dedef8b3199cb1fcd5b5f008e5240be2f08d')
+ 'c88201e1adeb5b50cfadfd55d071dedef8b3199cb1fcd5b5f008e5240be2f08d'
+ '635ac8ddb7150d4d3437471cbdf5f72bf5e9d11a1039adec84e04c78ee1a39c9')
prepare() {
patch --directory="${srcdir}/${_pkgname}-${pkgver}/bin" --forward --strip=1 --input="${srcdir}/sys-install.patch"
@@ -30,4 +32,6 @@ package() {
install -m644 -Dt "${pkgdir}/usr/share/licenses/${_pkgname}" "${_pkgname}-${pkgver}/LICENSE"
ln -s "/usr/bin/$_pkgname-mc" "$pkgdir/usr/bin/$_pkgname"
+
+ install -Dm644 "$srcdir/apalache.service" "$pkgdir/usr/lib/systemd/system/apalache.service"
}
diff --git a/apalache.service b/apalache.service
new file mode 100644
index 000000000000..ea9ee96714c1
--- /dev/null
+++ b/apalache.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Apalache Server
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/apalache-mc server
+ExecStop=/bin/kill -s SIGINT $MAINPID
+ExecReload=/bin/kill -s SIGINT $MAINPID ; /usr/bin/apalache-mc server
+Restart=always
+LimitNOFILE=4096
+
+[Install]
+WantedBy=multi-user.target