summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenri Chain2017-09-05 19:10:14 +0200
committerHenri Chain2017-09-05 19:11:52 +0200
commitddc8b881ead5187dbfcbe7ea73da072207ee9130 (patch)
treed650b7ef0f44ff0227a49486e8d8ddf62530ca61
downloadaur-ddc8b881ead5187dbfcbe7ea73da072207ee9130.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.install3
-rw-r--r--PKGBUILD33
-rw-r--r--alias.patch31
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60efab4e5600
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = apaxy-git
+ pkgdesc = A simple, customisable theme for your Apache directory listing.
+ pkgver = r78.af176b3
+ pkgrel = 1
+ url = http://adamwhitcroft.com/apaxy/
+ arch = any
+ license = public domain
+ depends = apache
+ provides = apaxy
+ source = apaxy::git+https://github.com/AdamWhitcroft/apaxy.git
+ source = alias.patch
+ md5sums = SKIP
+ md5sums = 803f84bf166110fd0d4869a681411200
+
+pkgname = apaxy-git
+
diff --git a/.install b/.install
new file mode 100644
index 000000000000..911f09a3bfd0
--- /dev/null
+++ b/.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo 'Add "Include conf/extra/httpd-autoindex.apaxy.conf" to your /etc/httpd/conf/httpd.conf to enable apaxy'
+}
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e95952e7fcd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Henri Chain <henri at henricha.in>
+
+pkgname=apaxy-git
+pkgver=r78.af176b3
+pkgrel=1
+pkgdesc="A simple, customisable theme for your Apache directory listing."
+arch=('any')
+url="http://adamwhitcroft.com/apaxy/"
+depends=('apache')
+provides=('apaxy')
+license=('public domain')
+source=('apaxy::git+https://github.com/AdamWhitcroft/apaxy.git'
+ 'alias.patch')
+md5sums=('SKIP'
+ '803f84bf166110fd0d4869a681411200')
+
+pkgver() {
+ cd "$srcdir/apaxy"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/apaxy"
+ sed -i 's:theme/:/apaxy/:g' ./apaxy/htaccess.txt
+ patch -p1 -i "$srcdir/alias.patch"
+}
+
+package() {
+ cd "$srcdir/apaxy"
+ install -D -m644 './apaxy/htaccess.txt' "${pkgdir}/etc/httpd/conf/extra/httpd-autoindex-apaxy.conf"
+ install -D -m644 -t "${pkgdir}/usr/share/httpd/apaxy" ./apaxy/theme/{footer.html,header.html,style.css}
+ install -D -m644 -t "${pkgdir}/usr/share/httpd/apaxy/icons/" ./apaxy/theme/icons/*
+}
diff --git a/alias.patch b/alias.patch
new file mode 100644
index 000000000000..3d8b46da0233
--- /dev/null
+++ b/alias.patch
@@ -0,0 +1,31 @@
+diff -ura apaxy/apaxy/htaccess.txt apaxy-mod/apaxy/htaccess.txt
+--- apaxy/apaxy/htaccess.txt 2017-09-05 18:12:25.910013018 +0200
++++ apaxy-mod/apaxy/htaccess.txt 2017-09-05 18:17:39.012425007 +0200
+@@ -5,17 +5,21 @@
+ # http://apache.org/docs/2.2/mod/mod_autoindex.html
+ #
+
+- # ENABLE INDEXING
+- Options +Indexes
+-
+ # INDEX OPTIONS
+- IndexOptions +Charset=UTF-8 +FancyIndexing +IgnoreCase +FoldersFirst +XHTML +HTMLTable +SuppressRules +SuppressDescription +NameWidth=* +IconsAreLinks
++ IndexOptions Charset=UTF-8 FancyIndexing HTMLTable IgnoreCase FoldersFirst XHTML SuppressRules SuppressDescription IconsAreLinks NameWidth=*
++
++ # Include apaxy resources at alias /apaxy/
++ Alias /apaxy/ "/usr/share/httpd/apaxy/"
++
++ <Directory "/usr/share/httpd/apaxy/">
++ #Options Indexes MultiViews
++ AllowOverride None
++ Require all granted
++ </Directory>
+
+ # META VIEWPORT
+ IndexHeadInsert "<meta name=\"viewport\" content=\"width=device-width, initial-scale=1\" />"
+
+- # HIDE /theme DIRECTORY
+- IndexIgnore .htaccess /theme
+
+ #
+ # GENERAL ICONS (BLANK, DIRECTORY, PARENT DIRECTORY)