summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrobot Viktor2019-04-05 21:37:38 +0300
committerDrobot Viktor2019-04-05 21:37:38 +0300
commit1ef3a52610685d77c88b3b5f0e9906496e519e9c (patch)
tree4cb0c21a448f9dc924557e1e1ce186ddc6dcd0d1
parent3a2576ea349cb44d28ae20c89a8694d9001aa774 (diff)
downloadaur-1ef3a52610685d77c88b3b5f0e9906496e519e9c.tar.gz
Fixed python versions
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c06fe7eab34f..b267fb78caf3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = apbs
pkgdesc = Electrostatic and solvation properties for complex molecules
pkgver = 1.5
- pkgrel = 3
+ pkgrel = 4
url = http://www.poissonboltzmann.org/
arch = x86_64
arch = i686
@@ -11,7 +11,7 @@ pkgbase = apbs
makedepends = gcc
depends = swig
depends = python2
- source = git+https://github.com/Electrostatics/apbs-pdb2pqr.git#commit=044f531f8fb944f7b14c9f34ff33833357b0fea4
+ source = git+https://github.com/Electrostatics/apbs-pdb2pqr.git#commit=aa353941cfadc09ccd113075d261a427864c2979
md5sums = SKIP
pkgname = apbs
diff --git a/PKGBUILD b/PKGBUILD
index 5469328a58e8..4318981be1cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
pkgname=apbs
pkgver=1.5
-pkgrel=3
+pkgrel=4
pkgdesc="Electrostatic and solvation properties for complex molecules"
arch=(x86_64 i686)
url="http://www.poissonboltzmann.org/"
license=('MIT')
depends=('swig' 'python2')
makedepends=('cmake' 'git' 'gcc')
-source=("git+https://github.com/Electrostatics/apbs-pdb2pqr.git#commit=044f531f8fb944f7b14c9f34ff33833357b0fea4")
+source=("git+https://github.com/Electrostatics/apbs-pdb2pqr.git#commit=aa353941cfadc09ccd113075d261a427864c2979")
md5sums=('SKIP')
build() {
@@ -27,4 +27,13 @@ package() {
cd ${srcdir}/apbs-pdb2pqr/apbs
make DESTDIR=$pkgdir install
+
+ # fix python versions in scripts
+ sed -i 's|/bin/python|/usr/bin/python2|g' ${pkgdir}/usr/share/apbs/examples/protein-rna/apbs_unix_dx.py
+ sed -i 's|/usr/bin/env python|/usr/bin/python2|g' ${pkgdir}/usr/share/apbs/examples/protein-rna/fit.py
+ sed -i 's|/usr/bin/env python|/usr/bin/python2|g' ${pkgdir}/usr/share/apbs/tools/manip/psize.py
+ sed -i 's|/usr/bin/python|/usr/bin/python2|g' ${pkgdir}/usr/share/apbs/tools/python/noinput.py
+
+ find "${pkgdir}/usr/share/apbs/tests" -name '*.py' -type f -exec \
+ sed -i 's|/usr/bin/env python|/usr/bin/python2|g' {} \;
}