summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKherim Willems2022-10-25 14:06:16 +0200
committerKherim Willems2022-10-25 14:06:16 +0200
commit42287961288703a8bbe00182a4e270d3a36a324b (patch)
treed618e0804dd91236e6fb7ac054409d399dfb4238
parent263bc044dc33c1db8a0ff205cb6c08e738e2892f (diff)
parentc8d01fd49c7ec295c38e6964b287f576b495bb68 (diff)
downloadaur-42287961288703a8bbe00182a4e270d3a36a324b.tar.gz
Merge branch 'release/v3.4.1-1'
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD123
-rw-r--r--globals_apbs.patch69
3 files changed, 75 insertions, 140 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab312e74441f..632d8c4a2718 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = apbs
pkgdesc = Software for biomolecular electrostatics and solvation calculations
- pkgver = 3.0.0
- pkgrel = 2
+ pkgver = 3.4.1
+ pkgrel = 1
url = http://www.poissonboltzmann.org/
arch = x86_64
license = custom
@@ -10,16 +10,21 @@ pkgbase = apbs
makedepends = git
makedepends = wget
depends = python
- depends = termcap
- depends = swig
+ depends = openblas
+ depends = suitesparse
+ depends = lapack
+ depends = arpack
+ depends = eigen
+ depends = boost
+ depends = boost-libs
+ depends = metis
+ depends = superlu
+ depends = gtest
provides = apbs
conflicts = apbs-bin
options = !makeflags
options = !buildflags
- source = https://github.com/Electrostatics/apbs/releases/download/v3.0.0/APBS-3.0.0_Source-Code.tar.gz
- source = globals_apbs.patch
- sha256sums = 3cf8b227a205cdcbd13246489427606f256f2356343fc954734fd39975e5cbdb
- sha256sums = 6bc1f2dc7a454aa8b0799641f78ee571ba04795821a9bcac356cbe496bdb3df6
+ source = https://github.com/Electrostatics/apbs/archive/refs/tags/v3.4.1.tar.gz
+ sha256sums = 644e6246fd37c9dd4172fc7be1763337082ab8584dbcd53e738c831b62c89bb2
pkgname = apbs
-
diff --git a/PKGBUILD b/PKGBUILD
index ae0db43d1d28..2babdbb7f839 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,97 +1,96 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Maintainer: Kherim Willems <aur@kher.im>
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
pkgname=apbs
-pkgver=3.0.0
-pkgrel=2
+pkgver=3.4.1
+pkgrel=1
pkgdesc="Software for biomolecular electrostatics and solvation calculations"
arch=(x86_64)
url="http://www.poissonboltzmann.org/"
license=(custom)
-depends=(python termcap swig)
+depends=(python openblas suitesparse lapack arpack eigen boost boost-libs metis superlu gtest)
makedepends=('cmake>=3.12' make git wget)
provides=(apbs)
conflicts=(apbs-bin)
-source=("https://github.com/Electrostatics/apbs/releases/download/v${pkgver}/APBS-${pkgver}_Source-Code.tar.gz"
- "globals_apbs.patch")
-sha256sums=('3cf8b227a205cdcbd13246489427606f256f2356343fc954734fd39975e5cbdb'
- '6bc1f2dc7a454aa8b0799641f78ee571ba04795821a9bcac356cbe496bdb3df6')
+source=("https://github.com/Electrostatics/apbs/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('644e6246fd37c9dd4172fc7be1763337082ab8584dbcd53e738c831b62c89bb2')
options=(!makeflags !buildflags)
prepare() {
- # patch APBS building issues
- cd "${srcdir}/${pkgname}-${pkgver}/apbs"
- patch -Np0 -i "${srcdir}/globals_apbs.patch"
-
- # get external modules
- cd "${srcdir}/${pkgname}-${pkgver}/apbs/externals"
-
- # mesh_routines
- mkdir -p mesh_routines/NanoShaper/Linux64
- mkdir -p mesh_routines/msms/msms_i86_64Linux2_2.6.1
- wget https://github.com/lwwilson1/mesh_routines/releases/download/v1.5/NanoShaper_Linux64 -O mesh_routines/NanoShaper/Linux64/NanoShaper
- wget https://github.com/lwwilson1/mesh_routines/releases/download/v1.5/msms.x86_64Linux2.2.6.1.staticgcc -O mesh_routines/msms/msms_i86_64Linux2_2.6.1/msms.x86_64Linux2.2.6.1.staticgcc
-
- # PBAM/PBSAM
- git clone https://github.com/Electrostatics/pb_solvers.git pb_s_am
- cd pb_s_am
- git checkout 7ca2a8a491c0cf746074053005fcae026acc4da5
- cd ..
-
- # FETK
- git clone https://github.com/Electrostatics/FETK.git fetk
- cd fetk
- git checkout 0c6fdeabe8929acea7481cb1480b5706b343b7e0
- cd ..
-
- # Geometric Flow
- git clone https://github.com/Electrostatics/geoflow_c.git geoflow_c
- cd geoflow_c
- git checkout 99446ec841647419411d23bad632d50405913a06
- cd ..
-
- # TABI-PB (BEM)
- git clone https://github.com/Electrostatics/TABIPB.git bem
- cd bem
- git checkout 322a8d66180285250cd2f01e6b60584efcba9b65
- cd ..
+ echo "Nothing to do here"
}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}/apbs"
+ cd "${srcdir}/${pkgname}-${pkgver}"
- mkdir build
+ # Create empty build directory
+ mkdir -p build
cd build
-
+ rm -rf *
+
+ # APBS compilation flags
+ APBS_STATIC_BUILD=OFF
+ BLA_VENDOR="OpenBLAS"
+ BUILD_DOC=ON
+ BUILD_TOOLS=ON
+ INSTALL_DIR=/usr
+ RELEASE_TYPE=Debug
+ ENABLE_PYGBE=ON
+ ENABLE_BEM=ON
+ ENABLE_GEOFLOW=ON
+ FETK_VERSION=57195e55351e04ce6ee0ef56a143c996a9aee7e2
+ ENABLE_iAPBS=ON
+ ENABLE_OPENMP=OFF
+ ENABLE_PBAM=OFF
+ ENABLE_PBSAM=OFF
+ ENABLE_PYTHON=OFF
+ ENABLE_TESTS=ON
+ GET_NanoShaper=ON
+ PYTHON_VERSION="3.10"
+
+ # Configure and compile
cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DENABLE_GEOFLOW=ON \
- -DENABLE_BEM=ON \
- -DENABLE_FETK=ON \
- -DENABLE_OPENMP=ON \
- -DENABLE_PBAM=ON \
- -DENABLE_PBSAM=ON \
- -DENABLE_PYTHON=ON \
- -DENABLE_TESTS=OFF \
- -DBUILD_SHARED_LIBS=ON \
- -DBUILD_DOC=OFF \
- -Wno-dev \
+ -DCMAKE_INSTALL_INCLUDEDIR="include" \
+ -DBUILD_DOC=${BUILD_DOC} \
+ -DAPBS_STATIC_BUILD=${APBS_STATIC_BUILD} \
+ -DBUILD_TOOLS=O${BUILD_TOOLS} \
+ -DCMAKE_BUILD_TYPE=$RELEASE_TYPE \
+ -DCMAKE_INSTALL_PREFIX=$INSTALL_DIR \
+ -DENABLE_PYGBE=${ENABLE_PYGBE} \
+ -DENABLE_BEM=${ENABLE_BEM} \
+ -DENABLE_iAPBS=${ENABLE_iAPBS} \
+ -DENABLE_GEOFLOW=${ENABLE_GEOFLOW} \
+ -DENABLE_OPENMP=${ENABLE_OPENMP} \
+ -DENABLE_PBAM=${ENABLE_PBAM} \
+ -DENABLE_PBSAM=${ENABLE_PBSAM} \
+ -DENABLE_PYTHON=${ENABLE_PYTHON} \
+ -DENABLE_TESTS=${ENABLE_TESTS} \
+ -DFETK_VERSION=${FETK_VERSION} \
+ -DGET_NanoShaper=${GET_NanoShaper} \
+ -DPYTHON_VERSION="${PYTHON_VERSION}" \
..
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}/apbs/build"
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
# install base components
make DESTDIR="$pkgdir" install
# install license
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/apbs/LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# cleanup conflicting symlinks
cd "${pkgdir}/usr/lib"
rm -f libamd.so libblas.so libsuperlu.so libumfpack.so
+
+ # Remove conflicting gtest headers
+ cd "${pkgdir}/usr/include"
+ rm -rf gmock gtest
+ cd "${pkgdir}/usr/lib"
+ rm -rf cmake pkgconfig
+ rm -rf libgmock.so libgmock_main.so libgtest.so libgtest_main.so
}
diff --git a/globals_apbs.patch b/globals_apbs.patch
deleted file mode 100644
index b5756c7747a2..000000000000
--- a/globals_apbs.patch
+++ /dev/null
@@ -1,69 +0,0 @@
---- src/pmgc/mgsubd.c 2020-05-30 04:47:30.000000000 +0300
-+++ src/pmgc/mgsubd.c 2020-08-19 13:08:27.503698756 +0300
-@@ -52,10 +52,12 @@
- * @endverbatim
- */
-
- #include "mgsubd.h"
-
-+double bf, oh, cputme;
-+
- VPUBLIC void Vbuildops(
- int *nx, int *ny, int *nz,
- int *nlev, int *ipkey, int *iinfo,
- int *ido, int *iz,
- int *mgprol, int *mgcoar, int *mgsolv, int *mgdisc, int *ipc,
---- src/pmgc/mgsubd.h 2020-05-30 04:47:30.000000000 +0300
-+++ src/pmgc/mgsubd.h 2020-08-19 13:08:54.266813098 +0300
-@@ -253,11 +253,11 @@
- int n3 ///< The third grid size
- );
-
-
- /// @todo Get rid of these globals in refactor
--double bf, oh, cputme;
-+extern double bf, oh, cputme;
-
- /** @brief This routine prints out some info and such from inside multigrid.
- * @author Tucker Beck [C Translation], Michael Holst [Original]
- * @note Replaces prtstp from mgsubd.f
- */
---- src/pmgc/mypdec.c 2020-05-30 04:47:30.000000000 +0300
-+++ src/pmgc/mypdec.c 2020-08-19 13:09:34.939813105 +0300
-@@ -52,10 +52,15 @@
- * @endverbatim
- */
-
- #include "mypdec.h"
-
-+double v1, v2, v3, conc1, conc2, conc3, vol, relSize;
-+int nion;
-+double charge[MAXIONS];
-+double sconc[MAXIONS];
-+
- VPUBLIC void Vmypdefinitlpbe(int *tnion, double *tcharge, double *tsconc) {
-
- int i;
-
- nion = *tnion;
---- src/pmgc/mypdec.h 2020-05-30 04:47:30.000000000 +0300
-+++ src/pmgc/mypdec.h 2020-08-19 13:09:56.172972195 +0300
-@@ -65,14 +65,14 @@
- #define ZLARGE 1.0e20
- #define SINH_MIN -85.0
- #define SINH_MAX 85.0
-
- /// @todo Remove dependencies on global variables
--double v1, v2, v3, conc1, conc2, conc3, vol, relSize;
--int nion;
--double charge[MAXIONS];
--double sconc[MAXIONS];
-+extern double v1, v2, v3, conc1, conc2, conc3, vol, relSize;
-+extern int nion;
-+extern double charge[MAXIONS];
-+extern double sconc[MAXIONS];
-
- #define Na 6.022045000e-04
-
- /** @brief Set up the ionic species to be used in later calculations. This
- * must be called before any other of the routines in this file.