summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrobot Viktor2018-12-05 18:53:32 +0300
committerDrobot Viktor2018-12-05 18:53:32 +0300
commita8e74afcedc5b8251468be478754887a7d2777e3 (patch)
tree7c86dd115771088b4632810461828fa4f2af1a6c
downloadaur-a8e74afcedc5b8251468be478754887a7d2777e3.tar.gz
First release
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4411f3bde543
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = apbs
+ pkgdesc = Electrostatic and solvation properties for complex molecules
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://www.poissonboltzmann.org/
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ makedepends = gcc
+ depends = swig
+ depends = python2
+ source = git+https://github.com/Electrostatics/apbs-pdb2pqr.git#commit=044f531f8fb944f7b14c9f34ff33833357b0fea4
+ md5sums = SKIP
+
+pkgname = apbs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd87f9b60763
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+pkgname=apbs
+pkgver=1.5
+pkgrel=1
+pkgdesc="Electrostatic and solvation properties for complex molecules"
+arch=(x86_64 i686)
+url="http://www.poissonboltzmann.org/"
+license=('MIT')
+depends=('swig' 'python2')
+makedepends=('cmake' 'git' 'gcc')
+source=("git+https://github.com/Electrostatics/apbs-pdb2pqr.git#commit=044f531f8fb944f7b14c9f34ff33833357b0fea4")
+md5sums=('SKIP')
+
+build() {
+ cd ${srcdir}/apbs-pdb2pqr
+
+ git submodule init
+ git submodule update
+
+ cd apbs
+
+ cmake -Wno-dev -DCMAKE_C_FLAGS="" -DCMAKE_CXX_FLAGS="" -DCMAKE_EXE_LINKER_FLAGS="" -DCMAKE_MODULE_LINKER_FLAGS="" -DCMAKE_SHARED_LINKER_FLAGS="" -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DPYTHON_EXECUTABLE=/usr/bin/python2 -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so -DPYTHON_LIBRARIES=/usr/lib/libpython2.7.so -DENABLE_PYTHON=ON -DBUILD_SHARED_LIBS=ON
+ make
+}
+
+package() {
+ cd ${srcdir}/apbs-pdb2pqr/apbs
+
+ make DESTDIR=$pkgdir install
+}