summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Brubeck Unhammer2015-07-14 10:22:19 +0200
committerKevin Brubeck Unhammer2015-07-14 10:22:19 +0200
commitfba6e79ad70da1b43dd84a714f1fa893e384ba29 (patch)
treecd947ff759a1b13bceb5160a9d86b0bc688e04b2
downloadaur-fba6e79ad70da1b43dd84a714f1fa893e384ba29.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
-rw-r--r--configure.ac.patch50
4 files changed, 121 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..1a8d582f05fa
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = apertium-en-ca
+ pkgdesc = Apertium language data for the English-Catalan (including Valencian) translator.
+ pkgver = 0.9.3
+ pkgrel = 1
+ url = http://apertium.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkgconfig
+ depends = lttoolbox>=3.2
+ depends = apertium>=3.2
+ source = https://downloads.sourceforge.net/sourceforge/apertium/apertium-en-ca-0.9.3.tar.gz
+ source = configure.ac.patch
+
+pkgname = apertium-en-ca
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f9cf4cd214d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = apertium-en-ca
+ pkgdesc = Apertium language data for the English-Catalan (including Valencian) translator.
+ pkgver = 0.9.3
+ pkgrel = 1
+ url = http://apertium.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkgconfig
+ depends = lttoolbox>=3.2
+ depends = apertium>=3.2
+ source = https://downloads.sourceforge.net/sourceforge/apertium/apertium-en-ca-0.9.3.tar.gz
+ source = configure.ac.patch
+ md5sums = c984145a73c10c332c45b92bb676c37a
+ md5sums = 69cf23698c83a2d4456a0b5c0f7d8a13
+ sha256sums = c56e1f1c3fece009dc7c6b68af70f04ca9fbdee8e4b5e2ed8ea603f2f22ef0d5
+ sha256sums = f8e473ed4b180976d09a772f5d5f0827a019c4ad3ca420a818e38c9402da72e3
+
+pkgname = apertium-en-ca
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8255bbb47df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Kevin Brubeck Unhammer <unhammer@fsfe.org>
+# Maintainer: Kevin Brubeck Unhammer <unhammer@fsfe.org>
+pkgname=apertium-en-ca
+pkgver=0.9.3
+pkgrel=1
+pkgdesc="Apertium language data for the English-Catalan (including Valencian) translator."
+url="http://apertium.org"
+license=('GPL')
+makedepends=('pkgconfig')
+depends=('lttoolbox>=3.2' 'apertium>=3.2')
+arch=('i686' 'x86_64')
+source=("https://downloads.sourceforge.net/sourceforge/apertium/${pkgname}-${pkgver}.tar.gz"
+ "configure.ac.patch")
+md5sums=('c984145a73c10c332c45b92bb676c37a'
+ '69cf23698c83a2d4456a0b5c0f7d8a13')
+sha256sums=('c56e1f1c3fece009dc7c6b68af70f04ca9fbdee8e4b5e2ed8ea603f2f22ef0d5'
+ 'f8e473ed4b180976d09a772f5d5f0827a019c4ad3ca420a818e38c9402da72e3')
+
+build() {
+ patch -p1 < configure.ac.patch
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ autoreconf -fi
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/share/apertium/modes"
+
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/configure.ac.patch b/configure.ac.patch
new file mode 100644
index 000000000000..a98d5fd31d1a
--- /dev/null
+++ b/configure.ac.patch
@@ -0,0 +1,50 @@
+--- src/apertium-en-ca-0.9.3/configure.ac.old 2014-10-06 08:20:42.497145582 +0200
++++ src/apertium-en-ca-0.9.3/configure.ac 2014-10-06 08:20:54.236332341 +0200
+@@ -12,39 +12,8 @@
+ AC_PROG_AWK
+ AC_CONFIG_HEADER([config])
+
++PKG_CHECK_MODULES(APERTIUM, apertium >= required_apertium_version, [], [PKG_CHECK_MODULES(APERTIUM, apertium-3.2 >= required_apertium_version)])
+
+-AC_DEFUN([PKG_CHECK_APERTIUM], [
+- APERTIUM_VER=0
+- PKG_CHECK_MODULES(APERTIUM, apertium-1.0 >= 1.0.0,
+- [
+- APERTIUM_VER=10
+- ],
+- [
+- PKG_CHECK_MODULES(APERTIUM, apertium-2.0 >= 2.0.0,
+- [
+- APERTIUM_VER=20
+- ],
+- [
+- PKG_CHECK_MODULES(APERTIUM, apertium-3.0 >= 3.0.0,
+- [
+- APERTIUM_VER=30
+- ],
+- [
+- PKG_CHECK_MODULES(APERTIUM, apertium-3.1 >= 3.1.0,
+- [
+- APERTIUM_VER=31
+- ],
+- [
+- PKG_CHECK_MODULES(APERTIUM, apertium-3.2 >= 3.2.0)
+- APERTIUM_VER=32
+- ])
+- ])
+- ])
+- ])
+- AC_SUBST(APERTIUM_VER)
+-])
+-
+-PKG_CHECK_APERTIUM
+
+ AC_PATH_PROG(XSLTPROC, xsltproc, no)
+ if test x$ac_cv_path_XSLTPROC = x
+@@ -55,5 +24,5 @@
+ then
+ AC_MSG_ERROR([You don't have xsltproc installed.])
+ fi
+-
++
+ AC_OUTPUT([Makefile])